Since last update (7th of January), I am not able to load correctly those scripts:

  scripts="{! join(',', $Resource.lodash, $Resource.trix, $Resource.quill )}"
  styles="{! join(',', $Resource.trixcss, $Resource.quillcss )}"
  afterScriptsLoaded="{! c.scriptLoaded }"

The action callback from ltng:require is never fired and there are no error messages appearing. Is there a way to be prompt about the failure on the script loading process ?

  • 1
    An other thing is when I push my code on Salesforce (using developer console or IlluminatedCloud on IntelliJ), nothing is re-build even with 10x refreshing the page..
    – Simonp
    Commented Jan 10, 2017 at 9:26
  • I'm also facing similar issues since Spring '17. The changes are not reflected even after repeatedly refreshing the page. Really annoying.
    – SE_User
    Commented Jan 10, 2017 at 11:10
  • @SE_User The lockerService is not part of this problem, I tried to disable it without any build success
    – Simonp
    Commented Jan 10, 2017 at 12:08
  • I did not mean nor mention anything about Locker Service in my previous comment. :)
    – SE_User
    Commented Jan 10, 2017 at 14:07
  • @Nicolas, if you can provide a sample repro (as a unmanaged package I could install into my org or a gist) I can have a closer look. I think 'referrer' related error in console is unrelated to the issue you are seeing with your static resources, but can have a closer look for you. Commented Feb 18, 2017 at 20:20

1 Answer 1


There is an issue with static resources in Spring'17 that is activelit being worked on. The issue is being tracked in R&D by W-3615844 if you want to reference this in any communication with support. This will be fixed asap - once we have the fix it will go out immediately (emergency release candidate already).

  • Thanks for the confirmation Doug. I tried approaching Salesforce Support with the internal issue number you gave above, to provide me the Known Issue link or be added as recipient to status update on this issue. The request seems to be out of scope for them. So do you have a link which we can Subscribe to in Known Issues database?
    – VarunC
    Commented Jan 11, 2017 at 13:44
  • I've now found the Known Issue for the internal issue number provided from this, thanks. For general sharing and status tracking for all, this is the issue link - success.salesforce.com/issues_view?id=a1p3A000000ers4QAA
    – VarunC
    Commented Jan 12, 2017 at 12:29
  • 1
    Hello, is there some news about this issue ? We are also victim of it :/ Commented Feb 15, 2017 at 16:39
  • I've asked the developer on my team that fixed the issue to chime in - we always work in the next release and then back port selected fixes to the current release(s) and during the cutover from one major version to the next this can often take time to reach the field (we have to get on the next available train after first convincing the conductor to give us a ticket). Commented Feb 15, 2017 at 20:23
  • @Nicolas could you please share some additional details about your setup. Fix for the original post was rolled out to production back in January. Commented Feb 15, 2017 at 21:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .