Chatter messages are one of the handy little features within Chatter. I'm often in a conversation in chatter with somebody when I need to make a private comment to them and don't want to go back to email or someplace outside of the system.

This is what SFDC Internal Chatter looks like for me: enter image description here

Here is what Chatter looks like the community: enter image description here

I can don't see any limitations in the chatter settings or in the community profiles. So I don't see why it isn't there.

Is that a feature that is not permitted in a community?

Any thoughts would be much appreciated!


Private (Direct) Messages in Chatter Communities is not a feature yet. Here is an idea you can vote on for that feature: https://success.salesforce.com/ideaView?id=08730000000kry4AAA.

Update: This feature is available as of the Spring 14 release.

  1. From Setup, click Customize > Communities > Manage Communities, then click Edit next to the community name.
  2. Click Miscellaneous.
  3. Change the desired settings.
| improve this answer | |
  • Bummer!! But thanks for the link Daniel. But I don't get why it isn't a feature yet when Private Messages are a feature even on FREE versions of chatter. – Paul Weaver Aug 15 '13 at 17:55
  • Daniel, can you link to or provide info on how to enable PMs on communities? I can't figure out how to enable it for our customer community! – smohyee Aug 24 '15 at 19:16
  • I just updated the answer. – Daniel Hoechst Aug 24 '15 at 19:20
  • Daniel thanks for the update. Those instructions are actually incorrect (at least for me), though they are the same as those listed on the spring 14 release notes. For my setup, I had to go to Setup-->Customize-->Communities-->'Manage', which takes you to the Community admin page. Then I went Administration-->Preferences-->Enable Private Messages – smohyee Aug 24 '15 at 20:18
  • I just copied them from the Spring release notes as I don't have an org I could check it on. – Daniel Hoechst Aug 24 '15 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.