3

I am getting this weird error, when using remote object and I am not sure what is going on:

invalid field specified. Ensure that you use the full API name for any custom fields

this field exist in my salesforce object enter image description here

I am successfully retrieving several fields, but when I add this one i get the error, I have tried retrieving using the shrothand

<apex:remoteObjectField name="AUD_Price__c" jsShorthand="AUD_Price"/>

and using

<apex:remoteObjectModel name="Product2" jsShorthand="P2" fields="Name,Id, AUD_Price__c">

I was thinking it could be a restriction in the field type, however from my current list that I am retrieving I have other currency and number fields.

What could be the issue that is causing this error?

4
  • Is it possible that your AUD_Price__c field comes from an unmanaged package? If so, you need to use a prefix to call the field. Jan 8, 2017 at 13:19
  • 5
    Also check the FLS for the field for the profile Jan 8, 2017 at 13:22
  • 3
    @MohithShrivastava You are right, this was from a site and it didnt had read access, this have fixed it
    – manza
    Jan 9, 2017 at 2:02
  • 1
    Added as answer .Please upvote or mark it answered so it helps others. Jan 9, 2017 at 2:04

1 Answer 1

6

The issue is here because the FLS for the field has not been provided . Please note that remote objects by default respect CRUD/FLS settings configured by your salesforce admins

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .