3

I'm having trouble getting VS Code to recognize any MavensMate tasks in my initial testings. I definitely have the MM desktop app installed and a working project for it (I've been using MM and Sublime up until now).

For example, open a MM project

Error: command 'mavensmate.openProject' not found

What am I missing to get this working?

3

I just experienced this problem myself on Windows. I resolved it by updating the VS Code path in the Mavensmate Desktop Settings (gear icon in the upper-right).

The path that worked for me was: C:\\Program Files (x86)\\Microsoft VS Code\\Code.exe

| improve this answer | |
  • This worked for me. Although I had to restart my computer though since MavensMate was running in the background. – dana Jul 17 '17 at 17:47
  • What path will work for the VS Code "executable" in macOS? – John_Henry Jan 4 '19 at 15:32
0

Looking at the GitHub issues list, looks like this is a known issue from a couple of months back, so hoping devs can resolve it soon.

| improve this answer | |
0

For anyone who comes across this question but is on macOS, you'll likely need to set this to "/Applications/Visual Studio Code.app/Contents/MacOS/Electron"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.