4

I have a process that runs a checkbox loop: that is upon insert it turns off checkbox and then 1 day later it turns it back on so that the process can evaluate everyday. Most importantly, it triggers an invocable process, which I can activate. However, I cannot activate the checkbox loop process which gives me this error:

"Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 847820140-53431 (-1237165483)"

Can someone please explain what this error actually is?

3

That gack is mentioned in this post, in which we're told is related to this known issue. You're encouraged to contact Tier 3 support if you get this error. They have a fix. They don't say what causes it, but it can also be fixed by rebuilding the process from scratch.

  • 2
    I've submitted a case. But I've also tried to rebuild the process from scratch and it will not allow it to active. Strangely invocable processes can activate but not ones triggered by record changes. I have another one that automates an approval process that works in sandbox but doesn't even activate in production. – Himanshu Dhungana Jan 7 '17 at 6:54
  • 1
    @HimanshuDhungana Curious. Perhaps there's an additional underlying issue that hasn't been patched. This answer is only an educated guess based on publicly available information. Let's hope Support can sort this out. We outsiders don't have access to gack codes and their meaning. – sfdcfox Jan 7 '17 at 6:55
  • My system admin can turn on the processes now, but as a delegated admin I can create a process but still not be able to activate. – Himanshu Dhungana Jan 18 '17 at 6:03
  • @HimanshuDhungana I'd love to help. I would. However, I'm only an outsider looking in. Remember to log cases, and hopefully keep the internal pressure strong. Salesforce lives to serve us developers, but we need to remind them of this. We are stronger as a community than we are as one. – sfdcfox Jan 18 '17 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.