6

I have a field email TL1 which have values populated by a workflow. Also I want to make this field as blank using NULL value in data loader. I have changed the setting of data loader "Insert null values". Still I am not able to change value to null. I have also tried to deactivate the workflow and tried still no success.

I am getting the error in data loader as "Invalid email address :NULL".

  • Are you using the word literal "null" or just have the value blank? – Girbot Jan 5 '17 at 21:24
  • Have you tried "" (empty string)? – Jagular Jan 5 '17 at 21:31
  • I am getting the same error @Jagular – kunal gupta Jan 5 '17 at 21:53
  • @Girbot: I am using the word null – kunal gupta Jan 5 '17 at 21:53
  • If the field type is email, then you can't update it to value "null" because that is not valid email address. May be you can change the field type from email to text and then update the values to empty string and then change the field type back to email. – javanoob Jan 5 '17 at 22:50
9

Since you have already changed the setting of data loader "Insert null values". so, in the .csv, email field will be blank. NO quotes, NO NULL word.

If you open the .csv in notepad or notepad++, it will show values like this where email and phone are showing blank:

NAME,EMAIL__C,Phone

Jup20,,

You should successfully load the data.

  • 1
    I tried with the above method but it did not get updated may be since the fields are pre filled by a workflow – kunal gupta Jan 6 '17 at 1:43
  • 1
    pre filled by a workflow means? and with which values? – Santanu Boral Jan 6 '17 at 1:45
  • 1
    @kunalgupta But In the post you mentioned that you deactivated the workflow? – javanoob Jan 6 '17 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.