4

Our managed app has several VisualForce based tabs. When I switch to Lightning Experience the tabs all display correctly along with the default "Home" tab which is initially shown selected with the slds-is-active styling. When I click one of our custom VisualForce tabs, it gets selected properly and the style of the tab reflects this with slds-is-active styling. However, when I click a second custom VisualForce tab the highlighting of the tab no longer works. It is missing the slds-is-active style. If I go back to home the highlighting works again. The tabs and pages are configured as follows...

Overview.tab

<?xml version="1.0" encoding="UTF-8"?>
<CustomTab xmlns="http://soap.sforce.com/2006/04/metadata">
    <label>Overview</label>
    <mobileReady>false</mobileReady>
    <motif>Custom38: Camera</motif>
    <page>Overview</page>
</CustomTab>

Overview.page

<apex:page tabStyle="Overview__tab" sidebar="false" applyBodyTag="false">
    This is overview page.
</apex:page>

Is there something I need to put on the Visualforce page to get it to stay highlighted?

Watch video: https://www.screencast.com/t/thzRE7upb

  • I have the same problem even with standard object pages if I use the app builder to override the default page layout - see my question. I have tried to contact Salesforce on this problem but could not get any results – Itai Shmida Jan 8 '17 at 6:49
  • Yes, looks like exact same issue. I spent all day trying different <apex:page> options but nothing works. I'm also seeing a crossdomain error in the browser console, see new video. – Chris Huyler Jan 11 '17 at 23:07
1

After working with Salesforce customer support (partner case 15485269), this issue which occurred in the Winter '17 release has been resolved in the Spring '17 release. I have tested on my own org where the issue occurred and verified their fix after it was upgraded to Spring '17.

  • Can you edit your question to include a Salesforce support case number, if possible, or a related issue for others to view and verify? If you aren't able too, that's alright, but having that link can be helpful in case of regressions. – battery.cord Apr 10 '17 at 19:12
  • 1
    Sure, the partner support case was 15485269. I'll add it above as well. I don't know that I can link directly to it, but if this works for others here it is... partners.salesforce.com/… – Chris Huyler Apr 11 '17 at 20:00
  • Doesn't look like it, but in case anyone else needs to contact support, being able to provide the number of a previous case can be useful. – battery.cord Apr 11 '17 at 20:04
  • Is custom object tab style work? for example if we give tab style like tabStyle="Custom_Object__c" Will it work? – Sagar Thoriya Jan 2 '18 at 5:49
0

This is a content settings issue in Chrome. Go to Chrome -> Preferences -> Show Advanced Settings -> Privacy -> Content Settings -> Cookies -> uncheck Blocks Third-Party Cookies and Site Data

  • No this is not the issue. I have that option unchecked already. – Chris Huyler Jan 13 '17 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.