1

I can not be able to access shipping street by using it as "{!$ObjectType.Account.fields.ShippingStreet.Updateable}" can anyone help me out which permission suppose to give to give access to site guest user.....

3

Do the have access to the account record? If so

  1. Setup -> Develop -> Sites
  2. Click site name
  3. Public access settings
  4. Provide permission to the associated profile (Shipping Address is the field name)

If they do not have access to the account

  1. Create a variable in the controller to hold the shipping street value
  2. Use that variable to update the records field via code.

(Do not provide access to it directly)

Without knowing the specific context to which you are trying to accomplish this it is hard to provide more detail

Per your comment below that you are trying to render based on the Updatable it will always evaluate to false since the guest user cannot "edit" the object.....You will have to reevaluate what you are trying to do

You could change to isCreateable

7
  • i have given access to account object of read and edit...!!! but i couldn't found any filed in public access - > object permission - > accounts - .> filed level permission (couldn't found any filed called shippingStreet Jan 4 '17 at 6:37
  • @ChintalSomaiya - Its called Shipping Address
    – Eric
    Jan 4 '17 at 6:38
  • <apex:outputPanel layout="block" styleClass="avTableRow" rendered="{!$ObjectType.Account.fields.ShippingAddress.Updateable}"> here it is not getting rendered even though i have given permission to Shipping Address Jan 4 '17 at 6:46
  • check my answer Jan 4 '17 at 6:47
  • yup that changes the answer a bit....No point in the rendering like that for account as it will never evaluate to true
    – Eric
    Jan 4 '17 at 6:49
2

Site Guest user can only have CREATE and READ access to Account object.

So, even if you assign FLS to Shipping Address field as Read or Edit, result will show false.

1
  • hey thanx for the help...!!!!@Santanu Boral Jan 4 '17 at 6:52
0

Open your site's salesforce setup page. There is a button called Public Access Settings, click that button and modify it there.

As shown in the below screenshot:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.