3

I'm getting a API_CURRENTLY_DISABLED error when I'm trying to call the ajax api (sforce.connection.create) from my public page. In my site's public access settings I see the the 'API Enabled' option is checked. Any ideas why I cannot call the ajax api?

4
  • Are you using a Developer Edition account or a trail Professional/Enterprise/Ultimate Edition? – erbdex Aug 12 '13 at 12:38
  • I'm using an EE production/sandbox orgs – Dedo Aug 12 '13 at 15:13
  • were you able to solve this ? – Rao Aug 12 '13 at 17:42
  • Does the account/profile your testing with have the API enabled? – Mike Chale Aug 12 '13 at 19:17
2

The public API isn't available for the guest user. It's explicitly blocked.

2
  • 1
    So what is the point of having the 'API Enabled' checkbox in the Public Access settings? – Dedo Aug 12 '13 at 21:12
  • You're right, it doesn't do anything. – Ryan Guest Aug 13 '13 at 0:09
0

Neither do Trial Enterprise and Ultimate Editions have API support, nor does Salesforce activate it on request.

Getting to a work-around, if you want to test the API, go for a Developer Edition account. Therein you can create multiple CRM users, manage Accounts and Contacts etc. But do note that the DE comes with certain restrictions that can be easily bypassed. This will guide you into it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.