1

There is a report on a dashboard, and a user is getting the error Error: The source report isn't available; it's been deleted or isn't in a folder accessible to the dashboard's running user. I tried it, and I'm getting the same error.

I checked the recyling bin, and did a soql query (see below), and I didn't see the report. Also the report folder has read access. What caused this error? How do I confirm that it was deleted, if that was the case?

List <Report > r = [select id, name, isDeleted, lastmodifiedDate  from report where isdeleted = true ALL ROWS];
    for (integer i = 0; i < r.size(); i++){
    system.debug(r[i].name + '       ' + r[i].id);
}
0

There are several potential solutions.

  • If the dashboard has been modified recently, the running user may have been changed, and the new running user doesn't have access to the specified report folder; either it was a personal report or the report is in a folder not accessible to the new running user. If you know whom the old runner was, try changing it back. (nivyaj- comment: DB hasn't been modified in months, and the running user is and has been a System Admin, so they should be able to see it. When I log into the DB, as myself or the running user, we both get the same error)
  • If the report itself has been modified recently, it may have been moved to a different folder, where the old folder was previously accessible to the running user, and the new folder doesn't grant that running user permission. Try moving it back to its original folder, or Unfiled Public Reports.(nivyaj comment: I can't find the report at all. I have the name, and possibly the ID (we refreshed a sandbox, so i'm using that id. but i can't find it in the report object or the recycling bin) when I ran the above query through force.com IDE
  • If the report folder has been modified recently, it may have had its sharing changed so that the running user no longer has access to the report. Try adding the running user to the report folder's sharing, or move the report to a folder that does grant access to the running user. (nivyaj comment: folder hasn't been modified since 7/18. The running user (sys admin) role is there as well as the user who reported the bug. I do not see the report listed in this folder!

  • If the user has been modified recently, a change in user roles or group members may have caused the report to lose sharing based on the folder permissions. You might need to restore the user's original role.

  • If all else fails, download the dashboards, reports, folders, and profiles into the Force.com IDE or Metadata Toolkit, and examine the dashboard's properties to figure out which report is configured for that component. From there, you can step through the items above to figure out what recent change caused the failure.

In other words, there are many reasons why you'd get this error. You cannot delete a report that belongs to a dashboard component (years ago, this was possible, but not any longer). Only by investigating all the recent changes to the system will you find the cause. It would go a long ways if you knew what the report was. Of course, you could skip all this hassle and just build a new report.

3
  • I tried what you said and added my comments above. What's bugging me is that you're right, a user shouldn't have been able to delete the report since it was connected to a dashboard. the DB hasn't been modified in months, but i can't find the report in the report sObject. so it doesn't seem as though it's been deleted. Also, the running user is a system admin, so I should see it.... Ugh! – PartOfTheOhana Aug 11 '13 at 15:59
  • System Administrators can't see private reports they do not own via queries, nor can they run them. Administrators may be powerful, but they cannot see everything. Try using the Force.com IDE. – sfdcfox Aug 11 '13 at 16:04
  • No luck in the force.com IDE. I checked out the .report folder, and it wasn't there. Also, the DB was not there either ( but it is online!) is it safe to say that the report was moved to a “my personal reports” folder by a user??? – PartOfTheOhana Aug 11 '13 at 17:34
1

Once the reports are deleted it wont be available in recycle bin.From the dashboard find out the source report name and query report object with name as system admin profile.If query returns none then report is deleted

Update:Also make sure to take metadata XML of reports and search report name in metadata XML

2
  • You might not be able to query it, if it is a private report. You'd need to use the Force.com IDE or some such. – sfdcfox Aug 11 '13 at 2:21
  • You are right if its private we will need to look into Reports metadata XML – Mohith Shrivastava Aug 11 '13 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.