2

I have a custom Community Builder page that is a custom "Standard Detail" page called "TransactionDetail" (i.e. a detail, list, and related list page were each created). I have a component I added to the page that takes a recordId in the design file, which I set to {!recordId} in the community builder.

When I try to navigate to this page, and pass an Id, the page shows Invalid Page and does not load anything. When I remove the parameter, and just navigate to /s/transactiondetail, the header for the page shows up as expected.

Here's what I'm using to navigate to the page (the URL ends up looking exactly how I want it to):

    var navEvt = $A.get("e.force:navigateToURL");
    navEvt.setParams({
        "url" : "/transactiondetail/"+srcId,
        "isredirect" :false
    });
    navEvt.fire();

The URL I end up navigating to looks like "/s/transactiondetail/[recordid]" just as I would expect, however it just shows Invalid Page. I commented out all of the custom code and just have "test" displaying in the component itself, so there's no code causing an error in the component itself.

I also tried creating a non-standard custom community page and adding the component, it gives the same result. Any help would be appreciated.

2

Disregard, I found that it was profile access issues. When accessing a detail page override, the logged in user's profile is checked before attempting to load any data or elements into the view.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.