0

I was playing around with reports and I used one of the standard reports Contacts & Accounts. It generated results.

I then tried going into custom report types and did the same thing. I selected Contact as the primary object and then Account as the secondary. After saving it, I selected this report type when creating the report but it generated 0 rows.

Here is how the custom report went.

enter image description here

Even if I changed it to the second option, the report would still have no rows returned.

And here is what the resulting custom report looks like. I added no filters.

enter image description here

And here is the resulting rows if I just selected the standard Contacts & Accounts report.

enter image description here

Any suggestions as to why this might happen? I thought the custom report had the same logic as the standard report...

UPDATE:

Here are the "folders" that I see on the custom report type.

enter image description here

And here are the "folders" that I see on the standard Contacts & Accounts report (there might be some additional things that my org customized that might not appear on some standard reports...).

enter image description here

2

You have to select Account as a Primary Object.

It's because when you have a Lookup Relationship field on the object anything you select in there is like a parent for the record, so when you want to see all Contacts related to Account, you have to use Account as a base to see all children. The reason you had Accounts relationship name available when you started with Contact as Primary is because you have Lookup relationship field to Contact in your Account object.

  • It seems to be working now. But why does switching it around make it work? I thought Salesforce said if I want a Contacts & Account, Contacts should be the primary object. – akcorp2003 Dec 13 '16 at 17:53
  • It's because when you have a Lookup Relation field on the object anything you select in there is like a parent for the record, so when you want to see all Contacts related to Account, you have to use Account as a base to see all children. The reason you had Accounts relationship name available when you started with Contact as Primary is because you have Lookup relationship field to Contact in your Account object. – o-lexi Dec 13 '16 at 18:03
  • @Oleksiy, you should edit that comment into your answer. – battery.cord Dec 13 '16 at 18:32
  • @battery.cord done – o-lexi Dec 13 '16 at 19:11
0

In first report CreatedDate is in current FQ is set. Try to remove that and then run report. It will display same result.

enter image description here

I tried to create same report nd when I remove the date filter and in Range select ALL Time it display the result.

  • I tried but it didn't... I changed the date to CreatedDate but nothing showed up. :( – akcorp2003 Dec 13 '16 at 16:48
  • @akcorp2003 check my updated answer. – Tushar Sharma Dec 13 '16 at 17:21
  • Thanks for the update! However, I did the exact same thing previously and still no results. I tried it again but still no luck. – akcorp2003 Dec 13 '16 at 17:40
  • @akcorp2003 just FYI in report creation I have select second option Record A may or may not have related B record. – Tushar Sharma Dec 13 '16 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.