0

I am facing one issue while using dataloader. I was upserting single Account records which has 2811 contacts using dataloader. But while upserting its throwing CPU time limit exceeded error. Then i tried to export some of contacts from my sandbox and i upserted account with 500 contacts then its working. Then i again imported 200 contacts and tried to upsert then also it was working. Later i imported all the contacts to total 2811(as before) and tried to upsert account, then also its works. But why it was throwing error at first?? I can not use the same workaround in production so its not working in production.

Please help.

1 Answer 1

0

Its because of the trigger existing in the object in which you are trying to load the records.

Solution will be - 1. Deactivate the trigger and load the records. Once records inserted, Activate the trigger.

  1. No need to deactivate the trigger. make the records insertion batch size to 10-20.
3
  • i reduced the batch size to 1 still its showing the error. and i dont want to deactivate the trigger. This error occures when i am upserting record.(In this case - update)
    – Sofiya
    Commented Dec 12, 2016 at 10:58
  • How manny related records are created or updated by the trigger. have you unchecked the Bulk load option. Commented Dec 12, 2016 at 12:05
  • 2811 related records are updated. Yes the bulk load option in unchecked.
    – Sofiya
    Commented Dec 12, 2016 at 12:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .