I'd like all members in a queue to receive a case email notification each time a case changes ownership from an user to a queue.

In the queue settings I leave Queue Email blank and Send Email to Members unchecked so all queue memebers should receive an email notification. However, none of the Queue Memebers receives it.

Only the user who owned the case before it was assigned to the queue receives an email notification becuase the Send Email Notification is checked when I changed the owner on the Case detail page.

How can the queue send a case email notification to all queue memebers?

Thank you!!

  • Can we automatically check the Send Notification Email when changing ownership of a case and selecting a queue?
    – Chicho
    Commented Aug 7, 2013 at 18:15

1 Answer 1


In case the documentation is unclear, if you don't check "Send Email to Members," they won't be notified. Consult the following truth table.

  • Send Email to Members [unchecked], Queue Email [blank]: Nobody is notified. All members are notified.
  • Send Email to Members [unchecked], Queue Email [not blank]: One email address is notified.
  • Send Email to Members [checked], Queue Email [blank]: All members are notified.
  • Send Email to Members [checked], Queue Email [not blank]: All members and one additional email address are notified.

Previously (before the Send Email to Members box), salesforce.com would notify one address or all members. There was no convenient way to suppress messages except to use a dummy email address on the queue email. Now, administrators have four options for whom to notify. The documentation appears to need updating, because it doesn't explicitly mention the "notify nobody" feature.

When this answer was originally written, it appeared to work the way the original question was phrased; that the Send Email to Members box had to be checked. However, it appears that either the test was faulty or the behavior was broken and later fixed. If you want to send an email to nobody, you must still supply a dummy email address, as mentioned in this support article.

  • I was sidetracked by this answer. sfdcfox, the first row, "Send Email to Members [unchecked], Queue Email [blank]: Nobody is notified", is not the behavior I receive. I had to follow something closer to this salesforce knowledge quide to stop email from being sent: help.salesforce.com/apex/HTViewSolution?id=000003900 . Thank you for what you did put up though, just posting so others do not get confused with your first row. Commented Dec 9, 2015 at 17:34
  • @NicMcBride You're right. I tested this before I wrote this answer-- it's been a few years, but I remember testing it because I assumed the documentation was correct-- but the behavior does now match the documented behavior (I just tested it again to be sure). It may have been a glitch all those years ago. I'm going to have to edit this.
    – sfdcfox
    Commented Dec 9, 2015 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .