1

I am trying to make a custom object available in lightning.

I need to have all standard buttons on this record page.

But I cannot find the "Edit" standard button for "Salesforce1 and Lightning Experience Actions".

As you can see in the image - there is no edit button to select from:

enter image description here

I have full access to the object, and in classic salesforce all is ok.

What can be my problem?

  • Did you overwrite your Edit button by any chance? – tugce Nov 30 '16 at 15:11
5

Probably you have overwrite your standard Edit button with a Visualforce Page and page is not available for Salesforce1. To make your visualforce page available for Salesforce1 and Lightning go to

Setup - > Develop -> Visualforce Pages -> Your visualforce page -> Click Edit -> Check Available for Salesforce mobile apps and Lightning Pages checkbox -> Save

After this you can see your button appear on Salesforce1 action on the layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.