1

I have a Detail Page Button on the Opportunity object that opens a url for conga composer. this is the button's code:

https://composer.congamerge.com
?sessionId={!API.Session_ID}
&serverUrl={!API.Partner_Server_URL_290}
&Id={!Opportunity.Id}
&Culture=he-IL
&ReportId=00O80000003XawR

On classic Salesforce this button opens a new window with conga and all is well. When I move my UI to lightning experience, this button does not work - I get this error:

Invalid session or the session has expired. (Lock IPs may be enabled.)

enter image description here

I have searched for this error message and came to a few web pages (Conga web site, Salesforce) that explain to do :

  1. Ensure "Lock sessions to the IP address from which they originated" is NOT enabled
  2. Ensure the user running the solution has "API Enabled" on their Profile
  3. Ensure you have not reached your maximum API request limit
  4. Check to see if your Salesforce server is down

Now all of these settings are ok in my user and profile and org, also - in classic it works perfect.

I have also checked the URL that is generated from the button - it is the same from classic and LEX UI:

https://composer.congamerge.com/composer8/index.html?
sessionId=mysamesessionid&
serverUrl=https%3A%2F%2Fna28.salesforce.com%2Fservices%2FSoap%2Fu%2F29.0%2F&
Id=0061A0000139JpE&
Culture=he-IL&
ReportId=00O80000003XawR

Why doesn't the conga button work from LEX?

3

Conga's support site indicates that the session id button doesn't work in lightning, and that the oauth form must be configured and used. composer button help

  • One additional item to consider, you cannot use Report Data in Lightning as you cannot Export Reports. For any related data, you will also need to migrate your reports to SOQL queries – CongaPete Dec 1 '16 at 22:58
  • Does this fix work in professional edition as it doesn't have access to VF/Apex? It doesn't seem to recognize the URL I create based off of the info in the link here. – dphil Mar 26 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.