1

I'm a bit lost on how to troubleshoot this issue. I've completed the Attributes and Expressions trailhead, ie passed the challenged however I'm unable to display the component, campingListItem, in my HarnessApp. I get this error:

This page has an error. You might just need to refresh it. Aura.loadComponent(): Failed to initialize application. An internal server error has occurred Error ID: 33374234-34842 (-1501584897)

.... code removed

When I remove the <c:campingListItem /> tag things load just fine. It doesn't matter where I put this component, here or in the campingList component the same error comes up.

So I'm at a bit lost on what's going on, and why I'm unable to load this component.


code of the component, CampingListItem:

<aura:attribute name="item" type="Camping_Item__c" required="true"/>

... code removed per forum guidelines

</aura:component>
  • OK so after some playing I've figured out if I removed the 'required' attribute option the component loads. Why? – Fifedog Nov 24 '16 at 19:35
3

It looks like you specified a required attribute but you are not providing it in your markup:

You said you are declaring your component like this:

<c:campingListItem />

But the component has a required attribute which you are not defining above. You should have something like

<c:campingListItem item="{!v.item}" />

Where v.item is of type Camping_Item__c.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.