I encounter an issue with one trailhead from salesforce : Lightning components basics. I finished the previous chapter about be "connected to Salesforce with server-side" and the project worked.

Now i'm working on events but, when i refreshed the page an error occurrs without indication to locate the error

My error (in french but the title translate it):

Une erreur interne du serveur s'est produite

ID de l'erreur : 764157212-41930 (726297854)

Number outside '()' change between each refresh. "726297854" is still the same

What can it be?

Some code from this trailhead


<aura:event type="COMPONENT">
    <aura:attribute name="expense" type="Expense__c"/>


    clickReimbursed : function(component, event, helper) {
        var expense = component.get("v.expense");
        var updateEvent = component.getEvent("updateExpense");
        updateEvent.setParams({"expense": expense});


<aura:component >
    <aura:attribute name="expense" type="Expense__c"/>
    <aura:registerEvent name="updateExpense" type="c:expensesItemUpdate" />
    <div class="slds-card">
        <div class="{!v.expense.Reimbursed__c == true ? 
                  'slds-theme--success' : 'slds-theme--warning'}">
            <header class="slds-card__header slds-grid grid--flex-spread">
                <a aura:id="expense" href="{!'/' + v.expense.Id}">

            <section class="slds-card__body">
                <div class="slds-tile slds-hint-parent">
                    <p class="slds-tile__title slds-truncate">Amout:
                        <ui:outputCurrency value="{!v.expense.Amount__c}"/>
                    <p class="slds-truncate">Client:
                        <ui:outputText value="{!v.expense.Client__c}"/>
                    <p class="slds-truncate">Date:
                        <ui:outputDate value="{!v.expense.Date__c}"/>
                    <p class="slds-truncate">Reimbursed?:
                        <ui:inputCheckbox value="{!v.expense.Reimbursed__c}"

  • 1
    Sometimes just logging out and back in or a hard refresh is all that is needed. Have you tried completely closing out your browser and logging back in? – Jenny B Nov 24 '16 at 18:54
  • 1
    Those error codes are internal to Salesforce and you can only really get a response via support. – Matt Lacey Nov 25 '16 at 0:21
  • Yes Jenny, i tried a today so the browser was closed. I also tried on Chrome and i get the same error. I don't know why but i can't access to the technical support. it it available with a developper editon ? – Tellimi Nov 28 '16 at 9:10
  • In case your components are using an APEX controller: check if your apex controllers are compiling. Had these similar exceptions myself a few times. Most of the times it was due to a dependent apex class that was not compiling. – Lieven Juwet Nov 30 '16 at 15:50

Check your apex controller and the doInit method in your lightning controller.js.

See if you are setting a value in the expense attribute, like so:

component.set("v.expense", response.getReturnValue());

The exception you are getting is an AttributeNotFoundException.

The attribute "expenses" was not found on the COMPONENT markup://c:expensesList

Looks like you're trying to set expenses and you should be setting expense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.