0

I am trying to import a custom object which has 18 digit id, even though it is 18 digit id, the import fails, & Error log say 15 digit id (seems like SF convert my 18 digit id into 15 digit which is highly unlike).As my column is already 18 digit, converting into standard 18 digit is not a solution. Please help how to import successfully. Error image

Even in Data Loader, Even though I have External Id field in Journal object, Data loader is saying NO external ID fields defined. And, when I tried importing, 18 digit ID is converted into 15 digit, & error log saying 15 digit ID is not valid (last 3 letter from 18 digit is automatically discarded during import operation in both Data Loader, & Data Import Wizard). External ID problem

Is there any implication of Match By filter during the mapping (if all related fields exist in next step) that might throw the error?I have exported all data from previous SF org by Data Export wizard, & all app & custom objects from previous org are moved to new org by unmanged packaging. I have tried both Data Loader, & Data Import Wizard.

0

When trying to use an ETL tool to get data into salesforce using External Id's you need to use the UPSERT operation. Then you will be able to match against the external Id field

When using the 18 character ID the case does not matter. If using a 15 character Id the case DOES matter. Salesforce will automatically convert the 18 character ID to the proper case sensitive 15 character ID. so do not worry about that at all.

As for the external ID field not showing up in dataloader, ensure that the FLS for the field is such that you have Edit access to the field

The error message you have presented in your question means that the Journal object IDs do not start with a00 Check the URL of an existing Journal record and see what it starts with.

  • Upsert also throws the same error, External Id not defined – tanmoy Nov 19 '16 at 22:55
0

"Data loader is saying NO external ID fields defined"

When creating Journal.External Id field, did you check this checkbox? enter image description here

You should see "(external ID)" after the field type like this

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.