3

It appears the SalesForce website does not work! If I go here (I have tried this in multiple browsers) https://help.salesforce.com/ and click Contact Support -> Open a Case, it redirects me to https://help.salesforce.com/hthome?err=1. It does this whether I am logged in or not.

This has been well documented, but apparently never fixed:

https://success.salesforce.com/answers?id=90630000000h3S5AAI

I am really surprised something so simple has slipped through the cracks.

How can I submit a support case?

  • The portal is opening fine for me to contact support. you can call them at their direct lines at 1800nosoftware and open a case based on what support your company enrolled for, Premier (or) Basic – Rao Aug 2 '13 at 16:19
  • 1
    Well I am not sure why myself and the several other people on that post I linked to above aren't able to do so. I only have a developer account, maybe that's why. – user1477388 Aug 2 '13 at 16:20
  • 1
    Yep I am unable to open a case from developer account too. Call them to get the case opened. – Rao Aug 2 '13 at 16:36
  • Yeah the issue is it is a dev account. What is the issue you are trying to create a case for? Maybe it's something that can be answered by the dev community! – Tim Smith Aug 3 '13 at 18:00
2

I think you might need to read the User Agreement for Developer Acccounts. I don't know what it says myself because we are also a customer, but given that these accounts are free it's very likely support is not included. The submission of a case online has been fine for many years, I'm sure its related to the Developer account User Agreement.

It would not be unprecendented for this to be the case. I remember having trouble finding out how to reach Google support before we were a paying company.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.