0

I want to set up a self-registration process for a community. When I submit the data from the registration form there occurs an error message:

Error occurred while loading a Visualforce page

It's not very helpful. So I got the idea to debug. But I didn't find out how to debug communities.

Can anybody help me please?

  • For that error it might just be permissions, but you can use the standard debug log from the developer console probably as guest user to capture a non-registered community user. – Dave Humm Nov 16 '16 at 11:16
  • Thank you, that works. Unfortunately the log is not very helpful. Here is the message: 14:35:13:000 CODE_UNIT_STARTED [EXTERNAL]|06658000003BRm1|VF: /apex/Exception – nwolny Nov 16 '16 at 13:46
  • What could the permission problem be exactly? – nwolny Nov 16 '16 at 13:47
  • Each profile can have the permission to use a visualforce page granted, you can check this either from the profile or the VF page security settings. – Dave Humm Nov 16 '16 at 14:37
  • Okay I checked that in the security settings. Could the problem has anything to do with the guest user? Normally when a community is created with the wizard automatically a guest user is generated. But I don't see the guest user in the system (under manage users). I installed the community with all communities -> new community and then I followed the steps from the wizard. – nwolny Nov 16 '16 at 15:06
0

You can create a custom Error page and use following two methods i.$Site.ErrorMessage ii. $Site.ErrorDescription In you Controller.

for more details please refer answer to following question
Error: Error occurred while loading a Visualforce page

Thanks,
Nachiket

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.