0

When logged in When I'm logged into salesforce, it shows available records, enter image description here

Following is From Public site. When I click Look up button on Account field,

enter image description here

No records found due to one of the following: There are no records of this type You don't have permission to see any of the records Records do not fit the filter criteria set by your administrator

Also in Security settings, there is Enable External sharing, tried that too. Appreciate any help on where to look for enabling to view records in Accounts look up on Public site. Thanks.

  • Did you actually try to search? By default, a lookup field shows recently used items, so if that user hasn't recently used any items, nothing will appear by default. – sfdcfox Nov 10 '16 at 4:24
  • Also, if you searched and got no result, try looking at the lookup filter. – Lance Shi Nov 10 '16 at 4:26
  • Thanks @sfdcfox Tried Search., Search with * , but no luck. – Pasan Eeriyagama Nov 10 '16 at 4:36
  • @LanceShi Thanks. It doesn't appear for guest profile. No filters set. – Pasan Eeriyagama Nov 10 '16 at 4:45
0

Found this,

I entered a Value in Search which is coming up within Salesforce search, then it's picking up the records.

But it did not show up any records when I clicked Go or when I tried searching with * . I hope this is being security measures for not providing external parties to view All records at public domain.

| improve this answer | |
  • 1
    Notice the label of the list "recently viewed". This if none of been recently view nothing will be there until you search for something – Eric Nov 10 '16 at 5:36
  • @Eric Yeah! Thanks :) , the much you struggle there is a more chance of fortune..! – Pasan Eeriyagama Nov 10 '16 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.