1

I just wanted to know if the below requirement is possible or not

I want to hide the Login button from my user detail page so that anyone will not be able to login as my user.

Could you please let me know if this is possible.?

Thanks

2

There can be 2 ways that login access to your account can be accessed.

1. Individual granting access permission This is time limited and done from your own profile, by going to My Settings>Personal>Grant Account Login Access and then selecting if Your Companies Administrator, Salesforce Support or support for any AppExchange apps can log in and for how long.

If the Login Access Policy to allow any administrator to login as any user is enabled then the option to allow access for Your Company's Administrator does not appear here. enter image description here

2. Login Access Policies

You can turn off the ability for any administrator to login as any user from the Login Access Policies page.

Setup>Administer>Security Controls>Login Access Policies. Then untick the Enabled box and save

enter image description here

  • Indeed it's either none or all. You can't block just your user from login-as functionality. – Guy Nov 8 '16 at 10:15
  • Everything is set to NO Access in Grant Login Access.I am not getting a option 'Your Company's Administrator' as i can see in the screenshot you mentioned – Samir Nov 8 '16 at 10:30
  • @Samir all you need to do is leave the Your Company's Administrator as 'No Access' and then nobody else is able to login as you. – Dave Humm Nov 8 '16 at 10:32
  • Company admin option is not visible to me :( .What can be the reason? – Samir Nov 8 '16 at 10:34
  • Are there any other administrators in the Org? – Dave Humm Nov 8 '16 at 10:43
1

Go to My Settings---> Personel---> Grant Account Login Access
and
change Access Durations to -- No Access --

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.