1

I have users with a default custom App. The default custom App has a default landing tab. On the profile, they have been given permissions to the app and the tab. However on login the selected app is blank, and the home page the standard chatter page.

blank selected app


on this mysterious blank app, the tabs seem to be chatter related

where did these come from?


The default app is available in the dropdown, and if the user selects it (or any other app they have available to them) everything works as I would expect

list of available apps


Can someone explain what this mystery blank app is? and how to get the user to have a selected app on login?


Update 1:

I raised a salesforce case for this issue and the almost 1 month since the case has been raised the salesforce agent tried the following.

  • edit profile
  • create new VF page for the tab to redirect to
  • create new Tab with and without redirect
  • create new profile

The issue is odd in that it only impacts a subset of users and there seems to be no pattern as to who or why the redirect is not working.

Tier 3 first suggested that it because the User records were created via an API process instead of the standard UI but this was quickly disproved.

The case has now gone to salesforce R&D... for what I thought was standard salesforce functionality.

The interim solution is to repeatedly recreate the impacted user records until the redirect works.

  • 1
    This might be issue with history, browser cache. Try to delete and login again. – MIX DML Nov 2 '16 at 4:16
  • 1
    Possibly default app is an app the user does not have a license (either SF or managed package) to use.... – Eric Nov 28 '16 at 1:35
1

So this was an easy one to solve......

I just had this happen to me, logged in and blank app in menu:

enter image description here

Note it ONLY seemed to happen while on the home tab.

The reason was the default app was set to an installed package where the license was expired:

enter image description here

When the package license was updated the app appeared while on the home page as expected. It boggles my mind that SF support did all that stuff to your org without first checking the one thing that was most likely to cause it (If the issue on your end is the same that is)

|improve this answer|||||
  • (un)fortunately the default app isn't from a managed package, and when SF support created a new app to make as the default on the profile it should have worked. I looked back further and the older impacted users (users from 1yr+ ago) have never had a default app from an installed package. – user2610036 Nov 28 '16 at 23:42
  • What is that profile default app set to? And license type? – Eric Nov 28 '16 at 23:44
  • mix of company community and full salesforce licenses. The profile default app is set to our own custom app and our own custom VF page. – user2610036 Nov 29 '16 at 2:34
  • It has to be an access thing to either the app of VF pages for those profiles. Who knows though, maybe a major bug. Start with one user and check access to app, ensure app is visible in community, all vf pages are visible, all tabs are visible etc. Can any users with the affected profile not have the issue? Perplexing – Eric Nov 29 '16 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.