0

So here I am, testing the new feature of Winter 17, which is allowing custom lightning component to be used in the Lightning App Builder (LAB, how convenient) in sandboxes !

I deployed the name of the org which is a requirement of the feature. No further requirement, nada. Went to the LAB, and to my surprise, the component didn't show up in the list List of lg components

For the moment I tried with the classic

<aura:component >

And I tried with the

<aura:component implements="force:appHostable,flexipage:availableForAllPageTypes">

No success so far.. Is there any markup or attribute I should add to my component that I didn't know of ?

Thank you in advance !

Edit 1 Saw that I had to add a design (source) to my component to make it available in the LAB, still nothing though in list of custom components

I'd like to add that the component is kind of independent in the way that it will only display buttons that will fire action to load a record page. So no need of force:hasRecordId

  • where are you trying to embed the component? Home page or Record Detail page? – Praveen Oct 28 '16 at 13:34
  • On the record detail page. And if possible a standard list view page as well – Simon Govaert Oct 28 '16 at 13:36
3

You need to implement flexipage:availableForRecordHome,force:hasRecordId interface in the component to make it available to be added to the Record Detail page.More info can be found here

  • Thanks for the doc link, I'll dig it out. Although the availableforallpagetypes should have done the trick. I'll share the answer asap :-) – Simon Govaert Oct 28 '16 at 13:45
0

All right, after digging up, found out where the issue was.

In the lightning component (LC) , I had

<aura:attribute name="records" type="CustomRecord__c[]" /> 

Which was poorly initiated. It horribly failed actually. When commenting the attribute that failed, the LC would show up in my list available LC.

Enabling debug mode for lightning component + implementing a standalone component with an app allowed me to find the issue

So when an attribute fails to load in the LAB, the component doesn't show up in the list !

Now that I fixed the error, I can enjoy my lightning component on all types of lightning page ! :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.