0

I have a custom lightning tab tab1 added to my app. When I click on the tab1 I could see the nav tab is active for tab1.

enter image description here

Now I'm trying to add another custom tab tab2 to my app. Now when I click on to the tab1 or tab2, nav tab isn't active to those custom tabs.

enter image description here

But this works when I try to navigate to the default tabs like home/contact.

enter image description here

Is this a bug / do we have any solution for this?

I don't have much code in those tab1 and tab2 components..

tab1

<aura:component implements="force:appHostable" >
    hello1
</aura:component>

tab2

<aura:component implements="force:appHostable" >
        hello2
    </aura:component>
  • share your code as well – Tushar Sharma Oct 23 '16 at 6:56
  • @TusharSharma it doesnt have much code in the tab components.. – Saravanan Baskar Oct 23 '16 at 7:29
  • You can active and inactive dynamically i n controller using aura:id's, ex: adding and removing classes. – Raj_SFDC Oct 24 '16 at 7:38
  • 2
    I have the same problem and have added a question [here] (salesforce.stackexchange.com/questions/140403/…), I think this is a bug and I have asked Salesforce to help me on it (for now they are looking at it) – Itai Shmida Oct 25 '16 at 8:57
  • I think its a bug . Did any of you filed a bug with SFDC ? – Mohith Shrivastava Oct 26 '16 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.