1

We are doing team development and using subversion to manage our files. Each developer has their own sf sandbox and local project files. They do development, and when done they commit to svn, so others can checkout and update their own environments.

The original project we have came from a package produced by another developer, which we synced down locally, then checked into svn. Those of us that installed the package, can do updates in force.com and sync to our own dev server without too many problems.

But we are spinning up new developers and I think they should be able to sync to their own server without installing the original package.

The problem is we get tons of these errors for all of our controllers: Apex class 'xyzController' does not exist.

I checked in the meta data and all of our controllers are selected.

What else can I try?

  • Sorry, tried to clarify my question, its complicated to explain, hopefully this is now more clear. – Joelio Jul 24 '13 at 19:12
2

Joelio, doing this type of development on SFDC is extremely difficult.

I've done a talk on it at Dreamforce: https://www.youtube.com/watch?v=HmzppTJg6N8

I typically use Git and add the files I don't want to track to the .gitignore, I would do the same with SVN and remove items that are part of your managed package.

Is your goal to work in Sandbox orgs off an original production org? Or to have developers working in developer orgs and merging the code somewhere else before going to production?

| improve this answer | |
  • Hi Jordan, watched the first part of the video and that is exactly what we are doing. So I am trying to start a new developer from source checked out from svn, and when we do save to server is when we are getting all these errors. – Joelio Jul 24 '13 at 19:09
  • We want each dev in their own sandbox for dev, using svn to commit changes once they test, then others can update and save to their servers. Then after all done use ant tool to push to staging sandbox I assume – Joelio Jul 24 '13 at 19:09
  • Yes, your on the right track. You need to basically manually remove the file that came down and pick & choose only necessary components in the package.xml so that they don't create conflicts when you are saving them to the server. – jordan.baucke Jul 24 '13 at 19:12
  • 1
    ok, finally figured it out, we were missing a label in metadata, and adding it was a pain, I guess there is a bug in the force.com ide where if you try to add a label it gives a null pointer exception, we were able to manually add and that one problem solved 32 errors upstream. Thanks for the help! – Joelio Jul 24 '13 at 20:48
  • 1
    Absolutely! It's a very tedious process and breaks the entire iterative development process. – jordan.baucke Jul 24 '13 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.