3

I have a lightning application in a managed package which I am testing across multiple orgs, and I ran into an issue today where the page would not load on a Trial (Enterprise edition).

Uncaught rerender threw an error in 'markup://one:auraContainer' [rerender threw an error in 'markup://aura:expression' [$ is not defined]]
throws at https://myorg-dev5.lightning.force.com/auraFW/javascript/x4ZmsozINtoTVrt_2eFxRg/aura_prod.js:2:15
Error,    at Error (native),    at new <anonymous> (https://myorg-dev5.lightning.force.com/auraFW/javascript/x4ZmsozINtoTVrt_2eFxRg/aura_prod.js:180:302),    at https://myorg-dev5.lightning.force.com/auraFW/javascript/x4ZmsozINtoTVrt_2eFxRg/aura_prod.js:1:1

It seems like it is trying to use jQuery without loading jQuery. I took a look at the console and I see another error

Invalid 'X-Frame-Options' header encountered when loading 'https://myorg-dev5.my.salesforce.com/0A3?setupid=ImportedPackage&retURL=%...
dcIFrameOrigin=https://myorg-dev5.lightning.force.com&sfdcIFrameHost=web': 'ALLOW-FROM https://myorg-dev5.lightning.force.com' is not a recognized directive. The header will be ignored.

Attempting to access the page breaks LEX in general, as can be seen here, leading to more errors and eventually crashing and displaying an error message in the console

gA {name: "AuraError", message: "Invalid component tried calling function [set] with arguments [v._menuItems,[object Object]]", tf: Array[6], severity: "QUIET", o: "InvalidComponent"…}

I do not see the same issue occur on any other versions, and this is my test result from testing across different types of orgs.

Free - Developer Edition WORKS
Active - Enterprise Edition WORKS
Demo - Enterprise Edition WORKS
Trial - Enterprise Edition DOES NOT WORK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.