1

I have access to several Salesforce Professional accounts with the API Access addon purchased. I also have a Connected App which I've created which I've oauth'd with Users with System Administrator privileges from these accounts.

With one of the accounts, this works perfectly. I can pull data via the REST API with no issues.

However, with some of the other accounts, I'm still receiving the error:

API_DISABLED_FOR_ORG: The REST API is not enabled for this Organization.

When trying to access the API.

From poking around inside all the accounts, I can't find any difference between them -- all the users who OAuth'd have Admin privileges, which should allow them to use the API.

Any idea what could be going on here?

2

I am pretty sure the REST API is a separate permission on the blacktab and it seems like they forgot to enable that one for you. You will need to contact salesforce support to resolve this.

| improve this answer | |
  • Thanks for the response. I'm not able to access the SOAP API either (same error). I do have a ticket open with Salesforce, so if this turns out to be the case, I'll accept your answer :) – John Ledbetter Jul 24 '13 at 18:05
  • This is actually the answer we got (after getting the run-around) from our salesforce rep. Thanks! – John Ledbetter Jul 26 '13 at 14:04
2

The API Add-On has always been a pain point with PE ... going way back to before REST API was even introduced. It's no surprise that it's problematic for you. It's almost completely undocumented as well.

| improve this answer | |
1

Is the application for your own company/enterprise? 'Partner' with salesforce over the ISV program, clear the review and get listed on AppExchange. The cost is 300$ for the security review.

This would enable the APIs for all of CE, GE, PE accounts from the application end. At the end, you would be accessing the accounts using APIs through a namesake application.

This is one way you can bypass their plans and policies.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.