0

I made a new app. Created an object called Test with a PK, text, and email fields. I added one record to my app and connected the data to Heroku via Heroku Connect.

After mapping Heroku displays that it sees 1 SF row (correct) but it has 0 db rows available for me to use.

None of the tutorials specify what has to be done to a field for it to be usable by Heroku. What should I do?

Thanks in advance.

3
  • After you create your mapping, Heroku Connect should query the data from Salesforce and insert it to your Postgres DB. What's the name of your app? I work for Heroku and can take a closer look.
    – alouie
    Oct 19, 2016 at 2:15
  • I am trying to work off of the phonechange sample code. Name is "phonechange-test" Oct 19, 2016 at 2:17
  • I believe I simply had to put more rows in my test table. Once I made a second one it worked fine. Oct 19, 2016 at 2:26

1 Answer 1

1

It seems that I needed >1 entries in my Salesforce object. The moment I added a second entry, Heroku synchronized the postgres database with my data.

4
  • Strange that the initial table load didn't work. I'll create an internal ticket to do some further investigation. I suspect that the row would have been inserted into your Postgres DB when the next Salesforce poll happened (the polling interval is set to a minimum of 10 mins for the demo plan). But it should have been inserted after you set up your mapping.
    – alouie
    Oct 19, 2016 at 2:41
  • 1
    Thanks for coming by so quickly to help. Also I tried to do the same thing a few times using just 1 row of data and got the same result before. Oct 19, 2016 at 2:42
  • Update: I tracked the problem down and have fixed it. When we were doing an initial table load or a reload, we were excluding any updates that were done in the past 5 minutes. We still do that, but now we do another poll of Salesforce immediately after a reload, so that we pick up any changes that we might have missed. Previously, we still would have picked up the changes on the next poll, but the time taken would have depended on your mapping's polling interval.
    – alouie
    Feb 17, 2017 at 19:54
  • Thanks for getting back to me. I am actually quite impressed that you would give an update after all the time that has passed. Feb 19, 2017 at 7:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .