1

I have used an html email template to send an email, which is having an image attached to it which is stored in "Shared Documents" folder.

But the recipient of the email is not getting the image, The code being used by me to send image is as follows :

<img alt="" src="/servlet/servlet.FileDownload?file=01511000000kqAz">

Pls help

1

You're going to need to use the full URL when adding images to email templates.

i.e. https://yourInstance.salesforce.com/servlet/servlet.FileDownload?file=01511000000kqAz

When an external user (someone that can't log into your salesforce) views an email, each and every image needs to be accessible with a full URL.

Make sure the document is "Externally Available".

For more information: Adding Images to Email Templates

0

https://nax.salesforce.com/servlet/servlet.ImageServer?id=XXXXXXXXXXX&oid=XXXXXXX" height="90" width="600"/>

replace nax with your salesforce instance replace id with the record ID of your document. (see instructions by EIE50 above ) replace oid with your org id found in Settings > Company Profile >Company Info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.