6

I just downloaded Data Loader 38.0.0. The login has changed - instead of popping up a web window to log in, it just asks for user name, password and login URL (default is login.salesforce.com). I've tried both the production instance I'm trying to load to and my dev org. Neither has trusted IP ranges so security tokens should not be an issue. Nonetheless I get Error: Check your username and password. If you still can't log in, contact your Salesforce admin.

The only login flow available to me in v38 is direct password authentication. I am offered OAuth in v37 and it works fine.

Any thoughts? Why was OAuth removed from v38?

  • Just wanted to add: I've been always logging into v37 via OAuth. There is no more visible OAuth option in v38. – Charles T Oct 17 '16 at 20:16
  • 1
    Just the message cited above in bold. Fortunately Data Loader leaves the old version intact as well so I was able to spin up v37 and do what I needed. But why is OAuth missing from V38?? – Charles T Oct 17 '16 at 20:28
  • 1
    @CharlesT I assure you that you need to include the Security Token if the IP address you are authenticating from isn't in the Trusted IP ranges :). My understanding is the Restricted IP addresses limits you to specific IP's, so the security token is no longer needed. – Daniel Ballinger Oct 17 '16 at 21:18
  • 1
    @CasparHarmer most of the people in my company who use the Data Loader are admins not devs. The version of Data Loader that could be downloaded directly from Salesforce for Summer '16 offered OAuth as an option. It's missing in the Winter '17 release. Asking admins to compile it themselves or get a compiled version from devs is not helpful. – Charles T Oct 17 '16 at 22:03
  • 1
    I stand corrected sorry - I just opened it and it is missing the oauth piece. If I manage to put it back, I'll let you know. Very sorry. – Caspar Harmer Oct 17 '16 at 22:08
5

As commented by Charles, v38.0.1 is now available:

DataLoader V38.0.1 fixed Oauth option missing issue caused by release script and a bug in field mapping UI after sorting by column names.


Partial answer, to at least get you going until the missing OAuth authentication can be resurrected.

You will need to append your security token to the end of the password unless your current IP address is listed under Trusted IP Ranges.

Conversely, if the Organization has restricted IP addresses enabled you will only be able to login from those IP addresses and you won't need the security token.

I'll try pinging the Salesforce Docs team to see if they can clarify the confusing point in the Data Loader documentation.


Caspars comment with the link to the Github project would be a good place to raise the missing OAuth issue.

Issue created by Mohith - New Version 38.0 of dataloader has oauth option missing

Randomly searching the projects code, it occurs to me that it will need to have access to the OAuth Client secret to get the flow started as the correct connected app. You can see this at line 86 of AuthenticationRunner. If the sfdc.oauth.clientsecret was missing from the config then you wouldn't even get the OAuth option.

  • 2
  • Thanks for getting this rolling. For the time being I don't see any conflicts in using the v37 data loader on a v38 org so I'll use that until I have confirmation that v38 is restored. – Charles T Oct 18 '16 at 4:08
  • 1
    Looks like it's been fixed. New release will take a bit to roll out to orgs but I downloaded it straight from GitHub and OAuth is back! – Charles T Oct 21 '16 at 21:17
0

Dataloader needs certain configuration in place in order to show the OAuth login option. You can add configuration to solve this. Also the issue is now fixed in V38.0.1. Please download latest release. https://github.com/forcedotcom/dataloader/releases

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.