1

Is it possible to have private chatter conversations with a customer community license?

  • There are no roles or sharing rules allowed
  • It doesn't seem to be possible to add a customer community user to a chatter group

Is it the intention that all customer community users can only have fully public conversations or am I missing something?

1

Are you trying to add the community member to a Chatter group that's within the org?

When communities are enabled the CollaborationGroup object gains a new field, NetworkId which determines which community it belongs to, i.e. groups don't span communities, they're distinct for each. If you switch to the community in question as admin you can create new Chatter groups in there for users to be assigned to.

According to the API documentation here, communities do not support private messages:

The /connect/communities/communityId version of the resource isn’t supported because Communities doesn’t support private messages.

  • Thanks! this might be what I'm looking for. I'm gonna play around with it some more. Is there any way to associate this group with a specific record? What I'd really like to do is allow a customer community user to collaborate around a specific record. – Phil B Jul 24 '13 at 1:13
  • Not directly that I know of, you could probably hook something up to do that. There are apps on the AppExchange that allow for auto following (one of which is ours but I don't want to promote here) of records, they could be of use. – Matt Lacey Jul 24 '13 at 1:20
  • Without getting too deep into it, if I create a EntitySubscription record for a Customer Community user I still get insufficent priv. error in the community when trying to show the chatter feed for the record even if the controller is without sharing. It will show up if I enable 'View All' but I obviously don't want to do that. – Phil B Jul 24 '13 at 1:54
  • Chances are they don't have access to the record in question, though one thing to check would be that the NetworkId on the EntitySubscription record is correct. – Matt Lacey Jul 25 '13 at 0:32
0

According to this Idea posting, this functionality has been delivered Spring 14: https://success.salesforce.com/ideaView?id=08730000000kry4AAA

However, I'm looking around for instructions on how to enable private messages in Customer communities without luck.

Edit: instructions below

Setup-->Customize-->Communities-->'Manage', which takes you to the Community admin page. Then I went Administration-->Preferences-->Enable Private Messages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.