0

I have set a Debug Log in my sandbox Org but it did not capturing any logs.

Please advice what it my be the reason for it.

marked as duplicate by Adrian Larson, Mohith Shrivastava, Tushar Sharma, Boris Bachovski, Ratan Paul Oct 13 '16 at 4:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

After the Winter 17 release, you need to set a server cookie in the browser to enable debug logs for Site Guest Users.

Your public users generate a large volume of events, which can quickly fill up your debug logs. For this reason, logs are collected for site visitors who are using your Guest User license only when a public user’s browser has a special cookie.

To enable logging for a guest user:

  1. Ask the user to set a browser cookie with a domain value of .force.com and a name value of debug_logs. Refer to the documentation for your user’s browser for information on adding cookies. To be able to add cookies, your user probably needs a browser plug-in or extension.

  2. Find the name of your Site's guest user.

    a. From Setup, enter Sites in the Quick Find box, then select Sites.

    b. Select your Site from the Site Label column.

    c. Select Public Access Settings | View Users.

  3. Set a user-based trace flag on the guest user.

    a. From Setup, enter Debug Logs in the Quick Find box, then click Debug Logs.

    b. Click New.

    c.cSet the Traced Entity Type to User.

    d. Open the Lookup for the Traced Entity Name field, and then find and select your guest user.

    e. Assign a debug level to your trace flag.

    f. Click Save.

You can also refer following post for this release update

Not the answer you're looking for? Browse other questions tagged or ask your own question.