1

I am using CloudConvert to generate previews of my files. CloudConvert is firstly getting call for URL:

URL: api.cloudconvert.com/process

And then, on the second call its Url changes to

URL: smt_instantly_changed.cloudconvert.com/process/another_instantly_changed_path

i.e.

URL: //host123d1qm.cloudconvert.com/process/cqpENkvYlnIja65TUZCH

How can add a remote sites to allow me make a HTTP Request?

  • simply add https://host123d1qm.cloudconvert.com/ in Remote site setting. – Tushar Sharma Oct 5 '16 at 12:22
  • however it is changing... not static.. for example host123d1qo.cloudconvert.com/process/20Bfr3nTeU6IotNslvmj host123d1qj.cloudconvert.com/process/mv1eYwdtH4GrjnfcQhLS host123d1qe.cloudconvert.com/process/S3Zt6DBqUg0R782XysbC", – efirat Oct 5 '16 at 12:32
  • then I afraid but you need to add all of them. Not sure if SF support http://*.cloudconvert.com/ you can try this. – Tushar Sharma Oct 5 '16 at 12:35
  • It does not support I've tried =) – efirat Oct 5 '16 at 12:38
  • 1
    I think, just last char of subdomain is changing... At least I can add for 28 letter. Even it is completely opposite to my programming prenciples =) – efirat Oct 5 '16 at 12:40
1

I told with cloudconvert support and they recommend me to setup a kind of proxy (I mean middleware server) to pass requests from salesforce to cloudconvert.

The second viable option is communicate with cloudconvert from client browser (make requests using javascript).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.