0

I have created a New DE having 5 fields

  • EmailAddress
  • FirstName
  • LastName
  • LinkClicked
  • SubscriberKey

Used for Sending Yes Used for Testing Yes

Of these Fields, LinkClicked and SubscriberKey are blank fields. While other 3 have values. I am having total 3 records. These records / email IDs are not present in all subscribers.

I have linked ContactKey to EmailAddress in Data Designer in one-one rel. Also marked it "Use as ROOT". Now I am creating a Journey using the above DE as entry source and schedule as Never. After activating the journey, I am firing an event on entry source DE using Automation Studio.

My Issues:

  1. When i go back and check the journey, no contacts are injected. Why ?

  2. If i also remove old records and import new records in my DE, and fire the automation, still it does not show any contacts injected. What am i missing here.

  3. Every time I have to mark it as Root again and again after sometime.

  4. Even when Subscriber and LinkCLicked fields are not present/ are deleted, the same issues are present, so i believe it is not linked to that. Is it true ?

Can someone guide me where is the problem and is there any step missing. Pankaj

  • Anyone .. can help ? – Pankaj Gupta Sep 30 '16 at 11:06
0

Can you be more clear by saying you have Rooted the data extension. As per July 2016 release, SFMC has stopped root relationships and instead replaced with Populations.

Deprecated Root Relationships

Instead of rooting the data extensions, you should be using populations:

Create a Population

If you have done Populations, only missing configuration as I could see is adding your email address in the contact configuration. Check if you have added your email address in the contact configuration. You can also add the default email address in Journey builder settings (I would prefer this as this is more reliant)

Chances are also that your contacts fell below the high water mark. Try inserting new records and test or if this is your test journey, you can delete the records in data extension and try.

| improve this answer | |
  • Thanks Ganesh/ Adrian, Can you clarify that if we create One-One relation with the DE which has the new contacts by creating it as a population, issue will be resolved ? Is there any step by step documentation or video tutorial because the online help from exacttarget is not proving to be of much help. :( We have a requirement wherein many contacts come in DE and we need to send them an email from within journey. However they are not in Subscribers list. Pls advise. – Pankaj Gupta Oct 2 '16 at 16:50
  • Under contacts configuration, no DE is appearing for us. - This will appear only if the DE has been updated in the populations else select the email address in journey builder setting . I normally refer to help notes and not sure if you have training videos for this configuration. For your requirements for sending mails to many contacts using Journey builder, Populations should solve the issue. – Ganesh Kumar Oct 3 '16 at 9:33
  • Thanks. Using Populations worked exactly as we wanted to. – Pankaj Gupta Oct 7 '16 at 4:05
1

As Ganesh points out, you will need to create a Population; don't attempt to edit the Root relationship option in the DE. The intent of a Population is that you link to an existing sendable DE containing your Contacts. However, in your case it sounds like those Contacts don't yet exist in the Contact model so it would make sense to use create a Population using event source DE as the Attribute Set.

Regarding your issue where the Email Address field is not appearing in Contacts Configuration, I assume that this is a sendable Data Extension and the EmailAddress field is type 'Email Address' not 'text'. Can you confirm?

Regarding your comment on the Contact not being in All Subscribers, when an email is sent, a Subscriber record will automatically be created for the Contact.

If you happen to be attending Dreamforce this week, I'd be happy to review your configuration with you.

| improve this answer | |
  • Thank You Eliot. We have multiple Data Extensions with EmailAddress field and type 'Email Address' but still Email Address field for any of them is not appearing in Contacts Configuration. Only the default Email Address field is appearing. I will check the solution you have given using Populations and update here. Also, Not attending Dreamforce yet. :) – Pankaj Gupta Oct 4 '16 at 7:13
  • It worked using populations. Thanks :) – Pankaj Gupta Oct 7 '16 at 4:06
  • Thanks for confirming that my answer resolved your question. Please can you accept my answer for the benefit of others. – Eliot Harper Oct 8 '16 at 5:35
0

Try storing emailaddress in subscriberkey (or whichever value you use as your subscriberkey) and tying to contactlist via the subscriberkeys instead of emailaddress.

Sometimes, emails that are not in the contact list will get rejected. ET told me that this can be worked around by prioritizing the DE's emailaddress over the contact list's email address (under contact builder > contacts configuration). I've still seen records rejected. as a workaround, i inject the DE's users into the contact list, then run the DE.

| improve this answer | |
  • Hi Adrian, Under contacts configuration, no DE is appearing for us. it is only showing Email Addresses : Email Address Not sure why is this. Also we have a requirement wherein many contacts come in DE and we need to send them an email from within journey. However they are not in Subscribers list. Pls advise. – Pankaj Gupta Oct 2 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.