0

I have an issue creating data set for my custom object in Wave Analytics. Can you help me to understand what needs to be done.

The user has permission set assigned, and the object is also accessible and fields too.

Error:

Error executing node 100: Fields [Survey_Unique_Name_or_ID__c, PG_Value_of_Contract__c, PG_Value_of_Core_Values__c, PG_Value_of_EPIC__c, PG_Value_of_Feedback__c, PG_Value_of_Intern_Seminar__c, PG_Value_of_The_LC__c, PG_Valued_team_member__c] are not available. Verify that the fields exists and that the Analytics Cloud Integration User profile has Read level access on the fields.

JSON:

{
    "100": {
        "action": "sfdcDigest",
        "parameters": {
            "object": "Survey_Results__c",
            "fields": [
                {
                    "name": "Name"
                },
                {
                    "name": "Survey_Unique_Name_or_ID__c"
                },
                {
                    "name": "PG_Value_of_Contract__c"
                },
                {
                    "name": "PG_Value_of_Core_Values__c"
                },
                {
                    "name": "PG_Value_of_EPIC__c"
                },
                {
                    "name": "PG_Value_of_Feedback__c"
                },
                {
                    "name": "PG_Value_of_Intern_Seminar__c"
                },
                {
                    "name": "PG_Value_of_The_LC__c"
                },
                {
                    "name": "PG_Valued_team_member__c"
                }
            ]
        }
    },
    "101": {
        "action": "sfdcRegister",
        "parameters": {
            "source": "100",
            "alias": "TestMySurReport",
            "name": "TestMySurReport"
        }
    }
}
1
  • Got the solution. I have given access to integration user. All set :) – Ajay Sep 29 '16 at 21:58
0

Got the solution. I have given access to integration user.

Wave analytics creates a integration profile when you enable it in the org. So for that profile we have to enable read access to the objects which you needed.

All set :)

2
  • Can you please be more specific? – Adrian Larson Sep 30 '16 at 0:30
  • @AdrianLarson :Wave analytics creates a integration profile when you enable it in the org. So for that profile we have to enable read access to the objects which you needed. – Ajay Sep 30 '16 at 2:31
0

I ran into this issue of field not visible to integration user- when I was trying to generate a dataset (connected data) from the custom object in the SFDC Local Org. Then after seeing this note, I noticed there is a profile created in the ORG as "Analytics Cloud Integration User" and in the profile settings>object settings> "custom object" and enable the read access under Field permissions - this fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.