0

I'm working with a client on a project and have encountered some very strange behavior with custom lead field mapping upon lead conversion. I've created two custom fields on Lead and Account, both called Domain__c.

On Leads, this is a formula that returns text: enter image description here

On Accounts, it is simply a text field: enter image description here

I have set up the custom field mapping: enter image description here

I would expect this to carry over to the account when converting a lead. However, when creating a test record, I can see the field is populated correctly on the lead: enter image description here

However, when I convert the lead (and create a new account in the process), this value does not get mapped correctly to the Account: enter image description here

Am I taking crazy pills? What am I missing here that is causing this mapping to fail? I've done this exact same thing in previous organizations, and I'm not sure what the issue could be.

  • are you sure you don't have a Domain field (non-formula) also on Lead? My experience is that formula fields can't be mapped on Lead Conversion (at least, not directly) – cropredy Sep 25 '16 at 0:55
  • Yes I'm sure there isn't another domain field that I'm unintentionally mapping. Also, as I mentioned, I've done this exact same mapping in previous organizations so I don't think it's a limitation of not being able to map formula fields. – Todd Sprinkel Sep 25 '16 at 2:32
  • @ToddSprinkel, I tried to replicate this in my org and it worked perfectly. Lead formula field is mapped with Account textfield. I believe, you are checking with the correct Account record as it is named with "Test". Sometimes, we create so many test records with the same name and make a mistake. – Devendra Sep 25 '16 at 7:27
  • I'm working in a fresh developer org, and there are only two accounts in the system (with different names) so this is not a case of checking the wrong test record. – Todd Sprinkel Sep 26 '16 at 14:50
  • Todd - well, I learned something new today re: formula fields and mapping. Not sure how I missed this before -- thanks. As for your issue, I'm assuming you've looked for triggers/workflows on Account that inadvertently clear Account.Domain__c – cropredy Sep 26 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.