2

I have enabled the Site in Salesforce.com and I am not able to find the Secure link the one with https:// in there!!

As per the release of Spring-13 there is no sign of the secure link for site as it use to be in the previous versions.

Help needed!!

Edited:

I might not have asked the question in the right way..

What I am doing is:

  • Created a force.com site and published a visual force page to it.
  • Trying to access in some other salesforce org.
  • But in IE I am having a security issue (popup) for Http and Http as my other Org is Https: and my site is Http.

Previously what happens when you create a Site it would give you a secure URL. HTTPS version also, but now I am not able to find that.

Do I need to enable it from Some where.

Note: i already tried making the Http to Https in my other Org's Page but it fails as no site is hosted on Https port for my force.com Site.

enter image description here

  • 1
    Hi and welcome to StackExchange. Please provide more details in your question, including (if applicable, which seems like it is here) a screenshot - this will greatly increase your chances of getting a helpful answer. – jkraybill Jul 18 '13 at 7:55
  • @jkraybill I edited the post as suggested now lets see.. – user614946 Jul 18 '13 at 9:21
  • Have you tried somesite.secure.force.com ? That is the normal secure URL for a Sites site. Also what edition are you publishing from? – jkraybill Jul 18 '13 at 14:33
  • already tried that one.. I am having unlimited edition – user614946 Jul 19 '13 at 3:50
2

Weird, so it does look like Salesforce recently changed how these URLs are managed. In one of my orgs, I can see that under "Custom URLs" I now have entries for both the secure and non-secure URL for the site. Both of these still work.

My site config

Given that you only see the non-secure one, you should probably file a case. You could also try manually recreating a secure.force.com URL in your Site, or possibly under Domain Management, but I suspect that won't work because it looks like the *.force.com domains are excluded from direct manual management.

| improve this answer | |
  • yes that is what I mean by the question as I have tried to create a custom one but salesforce is not letting me do that.. i raised a case with them lets see what happens.. – user614946 Jul 19 '13 at 8:51
1

Click on the 'Login Settings' button on the Sites detail page. On the next page that appears (the 'Login Settings' page), the Secure Web Address field notes the secure address to access the Site with.

| improve this answer | |
  • Yes but the problem is this that this will only be there if we "Enable the Loggin for Site" but in my case we didnot need the login enabled but needed the Secure Address. So Salesforce provided the answere we can have only one SSl for Our Prod only and not for Sandbox and Developer. – user614946 Jul 31 '13 at 9:12
  • I had to create a new Salesforce Site the other day on a developer sandbox. No authentication was configured for the site. The https domain was the same as the http domain. – beamso Aug 8 '13 at 0:16
0

I got the answer for this Question, I am uploading this info if any one need it so.

I contacted Salesforce and they told me that Salesforce only provide SSL or HTTPS Sites for the Production Org only and not for any Sandbox or Developer Orgs.

Mark as Answer if it helps you.

| improve this answer | |
  • This is a change then as it previously was there, ugh – Eric Aug 13 '14 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.