While sending an attachment as an email to be attached to the salesforce record.Salesforce is giving the below given error.

Generating server: mx1.madison.gov

6-2j26dncatawfg1112dv2uwxupq9hzfgmjrrlrn2rx48cxm93nt.8-dea8eae.c.le.salesforce.com mx1-asg.mta.salesforce.com # #SMTP#

Is this salesforce problem or it is the Internal company server problem as I could see that error mentions company server name also.But to me doesn't look like company server error.

  • 1
    I don't see an error here, just an email-to-salesforce server name and a salesforce.com mta (mail transfer agent) name. Maybe you're missing something?
    – sfdcfox
    Jul 18, 2013 at 2:14
  • Hi sfdcfox, While sending emails to salesforce for attaching to the Saleforce records,user is getting the following error. emailtosalesforce@jdm6g0a8jnln9wgahzdjsbwj.8dea8eae.c.le.salesforce. com (Undelivered): 551 Failed due to: SenderAuthorization
    – Sales
    Jul 18, 2013 at 17:52
  • possible duplicate of Why does Email to Salesforce think my emails are spam? Jul 24, 2013 at 19:22

2 Answers 2


551 Failed due to: SenderAuthorization

This means that the user or server wasn't authorized to send the email to salesforce.com. Check Setup > Develop > Email Services > (email service name) > View (email address). If there is a list of permitted senders, only those addresses can send an email into that email address. You can use wildcards to specify domains.

  • When I go to setup-develop-email services.I do not see anything it is all blank.I only see new email service button and that's all
    – Sales
    Jul 18, 2013 at 18:22
  • That's because you haven't added any services yet... Click on the "New Email Service" button and add your new service.
    – VictorKilo
    Jul 18, 2013 at 18:31
  • Hi VictorKilo ,This system has been up and running for the last one year and they have been using it without any problem.Now they have encountered this problem of sending emails.So I don't have to add any service,In fact,I went to setup,email,my email to salesforce ,there I do see settings which have been configured by the last company who setup this org.
    – Sales
    Jul 18, 2013 at 18:47
  • The user interface for this in SFDC can be a bit confusing. Under Develop | Email Services | <your email svc> there will be a list of allowed domains where whence email can be accepted. At the bottom of the screen are the configured email addresses xxxxxx.salesforce.com. Click View next to the email address used by your sender and there may be additional restrictions on allowed senders
    – cropredy
    Jul 18, 2013 at 21:18

This appears to be a Known Issue with a Release In Progress. The link documents a workaround.

Some customers experiencing issue sending emails using Email-To-Salesforce due to PRVS implementation


Some customers may have a email security mechanism implemented on their outgoing mail servers called "Bounce Address Tag Validation" (BATV). The mechanism determines whether the bounce address specified in an email messaged is valid.

Essentially, this method prepends following in envelope-from field of the email header:

(XXXXXXXXXX = numeric unique identifier)

Now due to a recent change on Salesforce side, our application servers are currently rejecting emails where the envelope-from in the email header has an email in the above format if an email is sent to E2S email address.


If a customer (on NA8) sends an email to their E2S email address or using Salesforce for Outlook Add Email button they may get a bounce back message with content similar to below:

emailtosalesforce@a-xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.c.le.salesforce.com (Undelivered): 551 Failed due to: SenderAuthorization


Currently, the workaround is to add your email address in PRVS format under Email-To-Salesforce, My Acceptable Emails setting:

Setup | Personal Setup | Email | My Email to Salesforce

For example:

Actual email: [email protected]

PRVS email: [email protected]

Note: The PRVS format can be retrieved from your email headers envelope-from or you can consult your internal IT to get the correct PRVS format email.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .