I'm facing an issue where scroll is not working in one of the newly released Lightning Base Component in the Winter '17 namely lightning:textarea.

The cursor even moves out of the textarea when tried to scroll down or upwards as shown in the screenshots posted below in the Salesforce1 app.

CODE: (to reproduce the issue in Winter '17 pre release org)


<aura:component implements="force:appHostable,flexipage:availableForAllPageTypes">
  <div class="outerContainer">
    <lightning:textarea name="myTextArea" value="Initial value" 
    label="What are you thinking about?" maxlength="300" class="lightningTextarea"/>


.THIS .lightningTextarea textarea{

Screenshot 1 (iPad)

enter image description here

Screenshot 2 (iPad) enter image description here

In case of Android devices, you'll be able to scroll by clicking on to the cursor and then trying to scroll up or down.

  • ui:scrollerWrapper also had similar issues but with the latest update it seems to be working. Can you check this lightning:textarea also after latest update. seems like this needs a fix from SF team. – Pintu Francis Oct 25 '16 at 9:35
  • @PintuFrancis No, there's no change, still the scroll functionality is not working in lightning:textarea. – SE_User Dec 6 '16 at 11:59
  • Summer '17 is round the corner and still the same issue persists! @DougChasman @TrevorBliss @JFParadis Can you guys please take a look at this? Also regarding the ui:scrollerWrapper issue? – SE_User May 9 '17 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.