0

I have recently upgraded my Android and iOS Apps with new ET journey builder versions.Totally followed the Learning App, but location based push messages not functioning as previous.

I can see bellow error log on Android.

09-12 17:08:18.339 7589-9166/com.gowireless.mobile I/~!ETPushService: Request Url: https://consumer.exacttargetapis.com/device/v1/location/{et_app_id}/fence/?latitude=6.9412908&longitude=79.8792491&deviceid=c5f7f6b40342ad6c7030231203d28740
09-12 17:08:22.389 7589-9166/com.gowireless.mobile E/~!ETPushService: HTTP GET StatusCode: 500
~!ETPush_ERROR:  ET PUSH SDK VERSION: 4.5.0 build 160400002
~!ETPush_ERROR:  APP VERSION: 2.6 : 330
~!ETPush_ERROR:  Debug version: true
~!ETPush_ERROR:  configureSdk() Initialized with: 
~!ETPush_ERROR:  Context: com.gowireless.mobile.MainApplication@428e5ea0
~!ETPush_ERROR:  ET App Id: {et_app_id}
~!ETPush_ERROR:  Access Token: {access_token}
~!ETPush_ERROR:  GCM Sender ID: {gcm_sender_id}
~!ETPush_ERROR:  Analytics: true
~!ETPush_ERROR:  WAMA: true
~!ETPush_ERROR:  Location: true
~!ETPush_ERROR:  Proximity: false
~!ETPush_ERROR:  CloudPages: false
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION AVAILABLE: true
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION: 8115000
09-12 17:08:22.399 7589-9166/com.gowireless.mobile E/~!ETPushService: Reason: Internal Server Error
~!ETPush_ERROR:  ET PUSH SDK VERSION: 4.5.0 build 160400002
~!ETPush_ERROR:  APP VERSION: 2.6 : 330
~!ETPush_ERROR:  Debug version: true
~!ETPush_ERROR:  configureSdk() Initialized with: 
~!ETPush_ERROR:  Context: com.gowireless.mobile.MainApplication@428e5ea0
~!ETPush_ERROR:  ET App Id: {et_app_id}
~!ETPush_ERROR:  Access Token: {access_token}
~!ETPush_ERROR:  GCM Sender ID: {gcm_sender_id}
~!ETPush_ERROR:  Analytics: true
~!ETPush_ERROR:  WAMA: true
~!ETPush_ERROR:  Location: true
~!ETPush_ERROR:  Proximity: false
~!ETPush_ERROR:  CloudPages: false
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION AVAILABLE: true
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION: 8115000
09-12 17:08:22.429 7589-9166/com.gowireless.mobile E/~!ETPushService: Posting an error event to EventBus.  Error was: Internal Server Error
~!ETPush_ERROR:  ET PUSH SDK VERSION: 4.5.0 build 160400002
~!ETPush_ERROR:  APP VERSION: 2.6 : 330
~!ETPush_ERROR:  Debug version: true
~!ETPush_ERROR:  configureSdk() Initialized with: 
~!ETPush_ERROR:  Context: com.gowireless.mobile.MainApplication@428e5ea0
~!ETPush_ERROR:  ET App Id: {et_app_id}
~!ETPush_ERROR:  Access Token: {access_token}
~!ETPush_ERROR:  GCM Sender ID: {gcm_sender_id}
~!ETPush_ERROR:  Analytics: true
~!ETPush_ERROR:  WAMA: true
~!ETPush_ERROR:  Location: true
~!ETPush_ERROR:  Proximity: false
~!ETPush_ERROR:  CloudPages: false
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION AVAILABLE: true
~!ETPush_ERROR:  GOOGLE PLAY SERVICES REQUIRED VERSION: 8115000

However, outbound push messages is functioning as expected without any issues.

1
  • Can you post the section of the logs from a debug build that pertain to the POST to get messages and is it possible that your account has not been provisioned for Geofence messaging? – Bill Mote Sep 14 '16 at 12:46
0

Can you post the section of the logs from a debug build that pertain to the POST to get messages and is it possible that your account has not been provisioned for Geofence messaging? The error you're receiving would indicate some Server 500 (or equivalent).

In the logs you will also be able to see the request URL. That URL can be cut & pasted into any browser, replaced your AppId, AccessToken, etc. and it should work.

I suspect this is an account provisioning issue though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.