0

I am facing a weird issue with Custom salesforce report on Partner Community.

Few of the fields which are otherwise accessible to the Partner user are not visible when the partner community user run the reports. The columns are visible when Standard salesforce user runs the report . The report is built on the Object 'A' it has a lookup relationship to Object 'B' which further has lookup relationship to Object 'C'. The fields which are missing from the report are B__r.C__r.field1__c,B__r.C__r.field2__c,B__r.C__r.field3__c.

I have tried troubleshooting the issue and I have tried the following :-

  1. I have checked the custom report type and fields are available in the same.

  2. Fields are available in Report builder and I can build report on them and this issue is occurring only for Partner Community Users.

  3. I have checked the FLS and profile settings for the Partner Community custom profile and everything in question is accessible to Partner comm user.
  4. As a partner community user I can navigate to the records and see the fields in question via standard salesforce Page Layout.

Is there a setting which prevents Partner user from seeing relationship fields in the reports?

4

When the org wide sharing setting for an object is set to Public Read/ Write, it does not allow reports for the object to be viewed via the partner portal for security reasons.

The workaround for this limitation is to change the org wide sharing settings to Private.

Please go to mentioned link for details.

https://help.salesforce.com/HTViewSolution?id=000004441

  • Thanks Gaurav it helped me figure out the reason. Thanks a ton :-) – Sf_Noob Sep 12 '16 at 12:28
  • 1
    Gaurav, please include relevant quotes in the answer as link only answers are not favoured here as the links can end up broken. - How to Answer – Dave Humm Sep 12 '16 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.