18

I'm a bit of a force.com IDE newbie - still learning. I'm trying to migrate a simple custom object (no fields) from one sandbox to another and I'm running into this error:

# Deploy Results:
   File Name:    package.xml
   Full Name:  package.xml
   Action:  NO ACTION
   Result:  FAILED
   Problem: Cannot deploy InstalledPackage in Package Manifest with any other types!

Any help would be greatly appreciated.

Thanks!

4
  • Welcome to SFSE! It would be helpful to know a bit more about the problem you're having here. For example, what tool are you using to do the deployment (Force.com IDE or Ant Migration Tool or something else)? It could be helpful to see your package.xml file, either included in your post (if it's not too long) or posted on a pastebin site and linked from here.
    – Benj
    Jul 15, 2013 at 3:29
  • 1
    Were you able to resolve this?
    – user3298
    Jul 15, 2013 at 20:27
  • What a headache this was. Rolling back to v27 worked for me as well.
    – user3681
    Aug 28, 2013 at 17:25
  • 2
    They've announced v28.0.1 which they claim fixes this problem. I've not yet tried it out, though. blogs.developerforce.com/engineering/2013/09/…
    – user3700
    Sep 18, 2013 at 13:29

7 Answers 7

12

I also recently upgraded to v.28 and get the same error for simply trying to deploy a single RecordType. The resulting message does not appear helpful as there isn't any InstalledPackage entry within my package.xml file (see below).

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>Case.Retail_Accounts</members>
        <name>RecordType</name>
    </types>
    <version>28.0</version>
</Package>

As for installing a previous version of the Force.com IDE plug-in you must FIRST remove the current version.

  1. Go to the Eclipse menu Help --> About Eclipse and click the Installation Details button at the bottom left of the dialog box.
  2. Select the Force.com IDE and click the Uninstall... button and follow the instructions.

SECOND, install previous version of Force.com IDE:

  1. Go to the Eclipse menu Help --> Install New Software...
  2. Enter "Force.com IDE" in the Work With: box and it should return Force.com IDE - http://www.adnsandbox.com/tools/ide/install/. Select this option.
  3. Be sure to uncheck the Show only the latest versions of available software in the bottom section of the dialog. This should present with a full list of all versions of the API available.

NOTE: You will most likely need to create a new Force.com Project once you install a previous version (ie. v.27). I doubt the project upgrade wizard can handle the change backwards.

In the meantime, hopefully SF will issue a patch to v.28 to fix this issue!

Hope this helps, Mike

4
  • Thank you mike. This was very helpful. I just loaded eclipse for the first time on my mac and installed all of the latest software and it fails due to the problem with the v.28 api
    – user3331
    Jul 18, 2013 at 20:47
  • Thanks @CloudMike - I had upgraded to V28 so I could work with approval processes but when I needed to deploy (of course, hours before the worldwide sales kickoff), I ran into the error. Reverting to V27 did the trick
    – cropredy
    Aug 21, 2013 at 21:32
  • This doesnt seem to actually work if you have the latest Force.com IDE rather than having eclipse with the plugin. Any suggestions around that? Any word if Salesforce are looking at this?
    – Kris Moyse
    Aug 30, 2013 at 15:38
  • Now there is a patch, see the answer by @andres-perez
    – BuddhiP
    Sep 26, 2013 at 7:17
4

Salesforce released a patch to the Force.com IDE this week (28.0.1.201309101331) which seems to have fixed the issue. If this has not fixed the issue yet, then you can always install an older version by following these steps: http://www.eltoro.it/apex/ArticleViewer?id=a07A000000T22EOIAZ

1
  • Installing 28.0.1 does fix it! Easiest option for Force.com IDE users.
    – BuddhiP
    Sep 26, 2013 at 7:15
3

I receive the same error message during deployment from sandbox to production after the upgrade of the Force.com IDE to the latest version (v.28) last week. Using Force.com IDE (v.27) it worked like a charm.

2
  • How I can get the version 27 now? I am trying to find it with no luck. Jul 16, 2013 at 22:44
  • When you go to Install New Software and enter Force.com IDE, you get this link adnsandbox.com/tools/ide/install Click and expand the Force.com IDE and you can see all the versions listed below, uncheck the 28.0 version and let others stay Jul 22, 2013 at 13:07
2

While I'm not sure it's the best solution try to remove InstalledPackage type from package.xml

More details here: http://blog.enxoo.com/en/2013/07/cannot-deploy-installedpackage-in-package-manifest-with-any-other-types-resolution/

0

There is another solution not yet mentioned.

You can avoid deploying with the IDE by using Change Sets from the Salesforce Web UI.

App Setup -> Deploy -> Outbound Change Sets.

From here it is pretty simple to deploy the code to your production instance, it also keeps the IDE usable during a deployment.

0

I fixed this by changing my package.xml to this:

<?xml version="1.0" encoding="UTF-8"?>
<InstalledPackage xmlns="http://soap.sforce.com/2006/04/metadata">
<versionNumber>1.0</versionNumber>
</InstalledPackage>

As described here: http://www.salesforce.com/us/developer/docs/api_meta/Content/meta_installedpackage.htm

Yes, the code above is the entire content of package.xml. Get rid of everything else in there and paste it in.

2
  • Can you clarify how this "fixed" deployment using the IDE? I tried deploying some static resources from one org to another. I stripped down my package.xml so that it was identical to what you suggest. I noticed that the IDE didn't do a proper synch between the source and dest orgs. All the components I was deploying had the "Add" action, even though they already exist in the dest. org. Then when I tried to deploy anyway, I got the following error: Problem: Cannot deploy InstalledPackage in Package Manifest with any other types! But there are no other types in my package manifest.
    – tlfu
    Aug 21, 2013 at 11:45
  • It's weird, it worked for me once then stopped working when I tried it again. It definitely worked once but then I couldn't do it the second time. Aug 23, 2013 at 11:29
0

There is a known bug in v28 of the Force.com IDE. Downgrade to v27 until this is fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .