When attempting to deploy profiles, you may encounter the error "Unknown user permission: SendExternalEmailAvailable". What does this mean, and how can you resolve it?

2 Answers 2


Set Email Deliverability to 'All Email':

Email Deliverability Setting

For unknown reason Salesforce automatically creates and removes this permission completely behind the scenes on all profiles based on the value of this setting. This will fail deployments that contain profiles from orgs where this setting is set to 'All Emails' where the target org has this setting set to 'No Access' or 'System Email Only'.

  • and yes it is a source org versus destination org issue, allow them to match and this problem also goes away Commented Sep 2, 2021 at 4:07
  • I updated with the 2 options: remove the metadata or update the deliverablility. Commented Sep 2, 2021 at 4:08

This relates to the "Send through External Email Services" setting in Setup. Go to Setup > Email Administration > Send through External Email Services to see the setting. According to the description of that setting,

"Allow users to send emails through Gmail/Office 365 when composing emails in Lightning Experience. The Send Email through External Email Services user permission is enabled by default on standard profiles."

To resolve this error, manually ensure that your settings match in the source and target orgs.

enter image description here

  • 2
    FYI, the "Unknown user permission" error often happens when the "from" org is a new version than the "to" org during the window when orgs are moving to a newer version.
    – Keith C
    Commented Sep 9, 2016 at 7:42
  • 1
    and if you don't see the option "Send through External Email Services", you need to set the "Access Level" in "Deliverability" to "All email". Commented Dec 6, 2017 at 9:50
  • 1
    This actually only seems to fail if the "Deliverability" is not set to "All Email" - I tried deploying even if the settings don't match and it fails in case deliverability is not "System Email", but succeeds if set to "All Email"
    – sskular
    Commented Feb 4, 2018 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .