0

When we change the opportunity owner, and we set the Send Notification Email checkbox to true, we do not receive a notification email. Where would be check the settings for this, and where can we choose the template that is being sent? Tia, Lily.

2
  • changing oppo owner on the Opportunity detail page? The template is OOB – cropredy Sep 7 '16 at 14:58
  • Yes that's right. However none of our users receive an email. Any idea where I can check which template is being sent? – Lily Sep 7 '16 at 19:43
2

Lily

You may be faced with this recent Known Issue.

When you have a Process Builder process activated (with update record action) on an object

If a user changes the record owner via the UI on that same object and checks the "Send Notification Email" checkbox, the new owner will not receive the owner change email notification

Workaround

The workaround is to do the email notification actions via standard workflow or Apex triggers

The second part of your question re: email template used is covered by the Help Documentation

For Cases in Professional, Enterprise, Unlimited, Performance, and Developer Edition organizations, the email text is determined by the Case Assigned Template setting specified in the Support Settings.

For other records, the email text is automatically generated and cannot be customized.

Here's what the Opportunity Owner change template looks like:

Opportunity Foo has been assigned to you. Please click on the link below to view the record.

https://xxx.salesforce.com/someId

Be sure to visit the Known Issues page and note the issue affects you (last count, over 260) so SFDC is more likely to listen to your pain.

0

To achieve this after you create the workflow rule,make sure that you create Workflow Actions.I see which you are already doing that is Field Update Workflow Action.To send out an Email Create 'New Email' Workflow Action.While creating new Email workflow action you can choose the Email template you desire to send and also the Recipient type.

0

Your processes might be causing these issues, but Salesforce has fixed this issue in its Summer '17 release.

It will be there in your critical update section. All you need to do is to activate the update.

Try check the "Critical updates" section in your Org.

Setup--> Type Critical updates --> Activate the "Stop Automated Field Updates from Suppressing Email Notifications" update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.