0

I have created a request form for our clients, and to provide access to the form I have developed a site URL for them to access the form.

There is a field called request date in the form it is showing up in the normal preview page in the SF platform.

enter image description here

but in the Site URL the request date field is showing only the label nat the input box.

enter image description here

Please advise

<apex:actionRegion renderRegionOnly="false">
    <table style="width:100%;">
        <tr>
            <td style="text-align:right;width:35%;font-weight:bold;font-size:11px;color: #4a4a56;padding-right: 2px;">
                <apex:outputLabel value="Request Date" for="RequestDate"/>
            </td>
            <td style="padding-left: 10px;">
                <apex:inputField value="{!prf.Request_Date__c}" styleClass="form-control" required="true" label="Request Date" id="reqdate"/>
            </td>      
        </tr>
    </table>
</apex:actionRegion>
4
  • Did you give the Site Guest User edit access on that field?
    – Adrian Larson
    Commented Sep 6, 2016 at 12:03
  • @adrianlarson Yes I did Commented Sep 6, 2016 at 12:04
  • @adrian please find the mark up i have included. Commented Sep 6, 2016 at 12:10
  • @SamuelRobert also give edit access as well of this field. Commented Sep 6, 2016 at 12:44

2 Answers 2

0

I have faced similar problem many a times and issue is mostly caused by Field Level Security. To Check you have given appropriate FLS follow below steps:

  1. Go to Setup->Develop->Sites->Click on label of Site to which this page belongs.
  2. Clcik on button named 'Public Access Setting' .It will open profile of site guest user.
  3. Navigate to Field level security section and click on object to which this field belongs.
  4. Make sure Read Access and Edit Access is given appropriately. You must have edit access for your case.
  5. Save FLS and revisit site page to check if it works.
3
  • I had given read access to that field still it did not show up the date field. Commented Sep 6, 2016 at 12:25
  • You need edit access and not read. Commented Sep 6, 2016 at 12:46
  • I have checked both boxes read as well as edit. Commented Sep 6, 2016 at 13:18
-1

If you have permission sets assigned to the Site Guest User, then make sure that you have given the edit permission for the date field (Request Date).

1
  • I already clarified this point in the comments...
    – Adrian Larson
    Commented Sep 6, 2016 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .