2

getting following error :

Unknown user permission: ChatterInternalUser 

while i am deploying profiles. following the xml file :

<types>
    <members>Accounting</members>
    <members>Catering Banquets</members>
    <members>Community User</members>
    <members>Food Beverage</members>
    <members>Front Desk Agents</members>
    <members>Front Desk Management</members>
    <members>Housekeeping</members>
    <members>Membership</members>
    <members>POS Register</members>
    <members>Platform</members>
    <members>Programs</members>
    <name>Profile</name>
</types>

for every profile this is coming.

thanks in advance.

4

There is a Salesforce known issue on this - there can be different permissions between different org types (e.g. dev and sandbox).

The only workarounds suggested in the article are:

  • Removing the reference to the user permission in the metadata manually
  • Removing the profile from the deployment

Both aren't ideal solutions, but you can vote on the idea to hopefully get it fixed.

  • oh yehh sure have to vote for that.. coz this might cause many problem like if have created profiles with different permissions and i cant deploy that permissions then i have to manually add that permission to target org. – patelkiran3090 Sep 2 '16 at 10:08
  • 1
    hi solved this error by just enabling the chatter option in target org. and it worked – patelkiran3090 Sep 2 '16 at 14:25
  • Good to know. Thanks @patelkiran3090 – SineadCoyle Sep 5 '16 at 10:17
0

you can solve this error by enabling chatter option on the target org. i just enabled it and worked.

  • I have chatter enabled and it still doesn't work. Do you mean the checkbox Enable in the Chatter setting? – mascot Sep 5 '18 at 21:00
  • yes @mascot check that checkbox and enable it. – patelkiran3090 Sep 12 '18 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.