2

I am loading data into Salesforce using data loader, After loading data I found that all the data value in Salesforce is updated with one day less. i.e if my csv had date value 2016/08/31 , In Salesforce it got updated with 2016/08/30. My PC is in IST time zone and my Salesforce instance belongs to EST timezone and the user credentials Timezone used in data loader is ‘(GMT-04:00) Eastern Daylight Time (America/New_York)’. Please let me know what went wrong. Thanks, Indrasen.

  • I'd -1 this for lack of research because the answer was ascertained via a simple googling ...but I'd also +1 this for the inclusion of relevant details about the 3 separate time zones. In the end, I still downvoted because this question has been asked, and answered, before (it's the second result in the related questions for me at time of writing). I will say that the answer on this question is better. – Derek F Aug 31 '16 at 19:45
6

From Salesforce help

Why do date fields import incorrectly when I use the Data Loader?

When importing date fields using the Data Loader, sometimes dates import incorrectly because the Data Loader converts the date specified in the imported .csv file to GMT. If your machine’s time zone isn’t GMT or if your machine’s clock adjusts for daylight savings time (DST), your dates may be off by a day. To prevent the Data Loader from adjusting the date when it converts to GMT, directly change the format of cells containing dates to reflect the native time zone.

  1. Open your .csv file in Microsoft® Excel®.
  2. In each cell in which you entered dates, add hour data to represent the native time zone. For example, if the date is June 9, 2011 and the time zone is GMT+8,enter June 9, 2011 8:00. Excel will reformat this to 6/9/2011 8:00.
  3. Right-click the cell in which you entered dates, and click Format Cells.
  4. Click Number | Custom.
  5. In Type, enter yyyy-mm-ddThh:mm:ss.sssZ. For example, if the cell was 6/9/2011 8:00, it’s now 2011–06–09T08:00:00.00Z.

From Knowledge Article

How can I ensure my dates are correct when loading with the Data Loader?

When loading data into date fields such as Opportunity Close Date using the Data Loader, the date displayed in the application is sometimes one day earlier than the date in the file.

The reason for this is that fields such as Close Date are actually date/time fields. When a date is loaded without specifying the time, the time is defaulted to 00:00 - midnight. When another user is in a time zone which is behind the current user's time zone, the date will show on the previous day. For example:

20 August 2008 00:00 in Paris is 19 August 2008 23:00 in London

Similar issues can arise when daylight savings time begins or ends.

Two simple solutions to this are: 1) Specify a time as well as a date when loading dates using the Data Loader. or 2) Switch your PC's time zone to Hawaiian time before starting up the Data Loader.


From Knowledge Article

"Date" and "Date Time" format in Data Loader and API

Data Loader can have have trouble importing changes to the "Date" and "Date Time" Data Type fields when your CSV file import doesn't use specific formatting or correspond with your org's time zone settings.

Here's the correct formatting to use so you can avoid errors and frustration:

"Date" field acceptable formats

YYYY-MM-DD YYYY-MM-DD hh:mm:ss YYYY-MM-DD hh:mm:ss YYYY-MM-DDThh:mm:ssZ YYYY-MM-DDThh:mm:ss.sssZ

"Date Time" field acceptable formats

YYYY-MM-DD hh:mm:ss YYYY-MM-DDThh:mm:ssZ YYYY-MM-DDThh:mm:ss.sssZ

Example scenarios

Scenario: If your org's time zone is set as "China/Taiwan time zone GMT+8":

"Date" and Data Loader time zone is GMT+0, GMT, or blank

Your example data in your import spreadsheet can be either:

2011-01-10 2011-01-10 00:00:00 2011-01-10T00:00:00Z 2011-01-10T00:00:00.000Z

"Date" and Data Loader time zone is GMT+8

Your example data in your import spreadsheet must be either: 2011-01-10 08:00:00 2011-01-10T08:00:00Z 2011-01-10T08:00:00.000Z

Note: If you set the hh:mm:ss to 00:00:00, the Import Date data in Salesforce will display the previous day ('2011-01-09' instead of '2011-01-10').

"Date Time" and Data Loader time zone is GMT+8

Your example data in your import spreadsheet must be either one of the below options in order to have the Date Time display exactly what you imported in spreadsheet:

2011-01-10 XX:XX:XX 2011-01-10TXX:XX:XXZ 2011-01-10TXX:XX:XX.XXXZ

Additional information about these format​s

XX:XX:XX or XX:XX:XX.XXX stands for the variable time you key in. The "T" in these strings indicates the beginning of the time element. "Z" is a special GMT designation. This information is only applicable for the latest version of the Data Loader

  • I was about to post the same thing. For what it's worth, Salesforce could stand to be a lot more clear about when this issue can occur. The first article mentions the local machine time, while the second article mentions org default time. From the OP's description, it would appear that the timezone setting for the user and the org default time zone are both ignored when using Data Loader. – Derek F Aug 31 '16 at 19:25
1

Rather than changing all of your csv data, try to go into the settings of Apex Data Loader and change the timezone to GMT

enter image description here

0

Try using 'America/Los_Angeles' timezone for data loader as i also got the same issue but then i changed timezone as'America/Los_Angeles' and then data is inserted correctly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.