2

In the release notes for Lightning, it states that Javascript buttons and links are not supported in Lightning, but Visualforce and URL buttons are. I have created the following Visualforce button on the Account object:

Account Object setup

However, I am not sure how to access this button from the Account record detail page because it does not show up as one of the actions:

Account Record Detail

My question is, how are custom buttons shown on the Lightning Record detail page, and how do I add/remove custom buttons from the page?

2
  • DId you mark you VF page Available for Salesforce1 and Lightning (Mobile)? It's a checkbox on your VF page definition
    – brovasi
    Aug 30, 2016 at 23:03
  • Yes, the page is marked available for Lightning. Aug 30, 2016 at 23:12

1 Answer 1

3

As per my comment, make sure you VF page is marked as Available for Salesforce1 and Lightning. Then the second thing you need to do is override the Salesforce1 and Lightning Experience Actions section in your page layout and add your button there instead of the normal place. You will will find your button available in the Salesforce1 Actions on the top of your screen. The order of your button list will define how it will be displayed in Lightning.

enter image description here

4
  • Do I have to switch out of the Lightning Experience back to Classic Experience to make this change? I don't see an "Edit Layout" option, only an "Edit Page" option when I click setup. Aug 30, 2016 at 23:31
  • Edit Page means edit the Lightning Page through the App Builder, which is NOT what you want. You can't Edit Layout from lightning anymore. You will have to either switch out to classic or go to the object definition and then open the page layout from there.
    – brovasi
    Aug 30, 2016 at 23:33
  • Usually for admin configuration, I prefer to use salesforce classic, which is way faster. That's a bit up to you.
    – brovasi
    Aug 30, 2016 at 23:35
  • We all learned new things every day. Got the same issue a few weeks ago.
    – brovasi
    Aug 30, 2016 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.